Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is new behaviour in OS X 10.6: when I get keychain dialog boxes asking me for my password or to approve use of my keychain, the Character Viewer appears over top.

I don't want to disable the Character Viewer completely because I use it; I just don't want it popping up at this totally unrelated time.

share|improve this question
    
Character Viewer? Or the Keyboard Viewer? For the latter see "How Do I Keep Snow Leopard From Showing the Soft Keyboard When Asking for a Password?" at superuser.com/questions/39451/… –  Arjan Nov 3 '09 at 17:33

3 Answers 3

With the Character Viewer open, on the lower left click the settings and select "Minimize Viewer on Application Switch".

Although it is odd that you are getting this behaviour. Did you change your language settings?

UPDATE:


I was able to replicate the exact same issue you were having and I can see how it can be annoying.

The way I got it to behave the same is by opening Character Viewer and adding a special character to one of my passwords, after doing that the annoying window would always open while the keychain access window was open.

Solution


What worked for me to stop the Character Viewer from popping up in front of the Keychain Access window

  • Keychain Access window is open
  • Open System Preferences > Language & Text > Input Sources
  • Uncheck Keyboard & Character Viewer and all the additional languages you have checked for your system (cannot uncheck default). If you already have only the default one set then add another keyboard (ex. US International); close and come back to this step.
  • Close System Preferences and then close the Keychain Access window.
  • Open System Preferences > Language & Text > Input Sources
  • Re-check Keyboard & Character Viewer and all the additional languages you had checked before for your system.
  • Open Keychain Access and edit an item within the chain, the Character Viewer should no longer be popping open in front of your Keychain Access window.
share|improve this answer
    
Nope, I haven't changed my language settings. –  Luke Andrews Nov 3 '09 at 15:05
    
I'm not sure this achieves what I'm looking for -- minimizing it just seems to make it a small box, but it's still there. –  Luke Andrews Nov 3 '09 at 15:09
    
Thanks! That's thorough. :) In the end, somehow the problem seemed to go away on its own, perhaps after installing an update to OS X. –  Luke Andrews Dec 11 '09 at 16:01
    
I haven't tried this again since the 10.6.2 update, but I know it was the solution for 10.6.1. Glad to hear it is fixed though :) –  ricbax Dec 11 '09 at 16:19
    
This worked for me on Mac OS X 10.7.5 when the character viewer constantly appeared in the "fast user switching" window. I added the second language, as mentioned at the end of step 3. Now the "character viewer" doesn't appear. –  lividsquirrel Sep 5 '13 at 8:44

Even easier... This article worked for me!

Do not dismiss the window via its close button. Instead, choose Hide Character Viewer or Hide Keyboard Viewer from the Input menu (looks like a flag).

enter image description here

share|improve this answer

I am not sure if this works, but why don't you try it:

  1. Open the System Preferences
  2. Click "Language & Text"
  3. Click the "Input Sources" tab button at the top
  4. In the big list box, uncheck the "Keyboard & Character Viewer"
share|improve this answer
    
He doesn't want to totally disable it... –  Josh Oct 29 '09 at 18:14
    
Exactly--I use the Character Viewer regularly, so I need to keep it enabled. –  Luke Andrews Nov 3 '09 at 15:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.