Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have a Netgear WGT624 set up as an access point to provide wireless access on our wired network. The wired network has one PC acting as a DHCP server and internet gateway - the WGT624 is set up with a fixed IP and DHCP turned off, and is connected to one port of the wired network's switch. It all works OK except that it won't hand out more than 1 IP address to wireless devices. If a second one comes along is just sits there trying to get an IP address. If we turn off the connected device, the other one connects straight away.

My settings are (only stuff different to factory reset settings listed):

changed SSID region Australia channel 3 mode to b only (thought this might the problem) security WPA-PSK, set passphrase fixed IP address 192.168.0.254 (gateway is 192.168.0.1) DHCP off

Hardware is NetGear WGT624 V2 Firmware V4.2.11_1.0.1

If I do an IP scan on the network the addresses taken are (192.168.0...) :

  • 1 (gateway, wired, fixed IP)
  • 176 (PC, wired, DHCP)
  • 185 (PC, wired, DHCP)
  • 187 (PC, wired, DHCP)
  • 209 (Android S4 phone, wireless, DHCP)
  • 254 (WGT624, wired, fixed IP)

The S4 works fine. If I try to connect from any other wireless device I can't. The gateway is using the Win XP internet connection sharing.

If I turn off wifi on the phone and then turn it on again, it always gets address 209.

If I turn off wifi on the phone and then turn on wifi on an android tablet, it gets allocated address 77.

If I turn off wifi on the tablet and then turn it on again, it always gets address 77, and the S4 phone won't connect.

What I tried next was setting the wireless devices to all get static IP addresses 100, 101 and 102. All 3 devices (2x S4, one Sony tablet S) connect OK and seem to work.

So it appears as if this might be a workaround, but I would rather DHCP was working than having to set up anybody who visits with a static IP address.

Any thought on this appreciated.

share|improve this question

1 Answer 1

The Netgear WGT624 is a wireless router, not just an access point, so what you have right now is in effect a second network segment, routed by the WGT624, which is configured to use your actual network the same way it would, for example, a cable modem.

What you need to do, if possible, is configure the WGT624 to act as a wireless bridge, which will make it transparent; DHCP traffic will pass through from the main network, and your devices connected wirelessly to the WGT624 will be properly assigned DHCP addresses and otherwise be able to behave as any other device on the network. Unfortunately, most routers don't offer a bridge mode option, so you're probably out of luck there.

Failing that, you'll need to turn on DHCP on the WGT624 and let it assign addresses within its own range to devices which connect to it wirelessly; you'll also need to configure its DHCP address assignment range not to overlap that of your PC that's doing Internet Connection Sharing, or you'll get IP address conflicts. This is less than ideal, as devices connected to the WGT624 will have trouble communicating with those on the wired network, but it will allow more than one wireless device to connect simultaneously via the WGT624.

Of course, what would really be ideal would be to use the WGT624 as your gateway router, the role for which it is intended, and demote the XP box to a mere client; ICS can be made to work, but it's flaky, relatively slow, and a pain to administer. Is there some reason you can't do that instead of dealing with all this other nonsense?

share|improve this answer
    
Thanks for your answer Aaron. This use of the WRT624 seems to be an intended mode (see kb.netgear.com/app/answers/detail/a_id/19852/related/1) so I still think it is supposed to work. One minor problem with setting the DHCP range with ICS to avoid conflicts is that there is no easily accessible setting - I think you have the burrow into the registry. –  rossmcm Jul 31 '13 at 21:23
    
... The Internet modem connects to the current gateway via USB and there is a "dialler" app that runs on the PC, though I think you can also connect it direct with a cat5 cable. If I ran it in the mode with the WGT as the gateway, presumably I would connect the Internet modem to the 5th port of the WGT, but how do I bridge between the WGT and our existing wired 16-port switch? Do I just connect one of the 4 LAN ports of the WGT to one of the 16 ports on the switch, giving me 15 + 3 ports remaining? –  rossmcm Jul 31 '13 at 21:24
    
@rossmcm That's exactly right; you'd just plug the switch into a port on the router. The switch may have a port dedicated for this purpose ("uplink" is usually how these are described); if so, use that one, otherwise any should work. –  Aaron Miller Aug 1 '13 at 14:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.