Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having very many issues with my backtrack 5 r3 distro. Here's the list and specs.

Build Specs

BackTrack 5 r3 GNOME - 32bit ISO

4.0GB Sandisk Curzer USB 2.0

Unetbootin


Issues

No user login, I have changed the root password but I am never prompted for a username or password. When loaded into the GUI via "startx" I am automatically assigned to "root" profile.

Once loaded into the GUI the taskbar is filled infinitely with the task "Starting File Manager" this is constantly repeated until the icons are so small there just little black bubbles.

Also there are no icons on the desktop ( the backtrack 5 r3 was supposed to have a setup icon with it on the desktop ) and icons cannot be placed onto the desktop I've tried left click drag, right click place on desktop. Also I don't know if something is supposed to happen when you right click the desktop itself but nothing happens.

And also, I've had to do this 3 times now, you must reload the system to the usb because when you leave the system on for a longer time and the GUI loads up I get many errors that that ask if I want to delete files because they are faulting my system.

I cannot browse through the C: drive and nothing that opens folders such as "Home Folder" will actually even load to show a window.

I am basically stuck with the apps and terminal with nothing to browse or icons to arrange, and many errors upon startup.


Note

I haven't changed any settings within the system itself, I have only connected to my own network, and run console commands such as:

apt-get update
apt-get install
msfconsole
msfcli

If anyone could help me on this and please not redirect me somewhere like the backtrack forums,( I tried there and you cannot register anymore to post), I would truly appreciate it.

Also I will update this once I have a video showing the issues.

share|improve this question
    
Did you upgrade to 12.04? Doing so breaks backtrack. Also backtrack is supposed to run as root, not any other user. –  spuder Jul 31 '13 at 21:25
    
no I don't even know how to lol @spuder –  cmd Jul 31 '13 at 21:33
    
also while I have you, how do I install all packages from apt-get update? I've tried apt-get install but you have to specify the thing to install, how can I install all at once? @spuder –  cmd Jul 31 '13 at 21:34
    
There really isn't a need to run apt-get update or apt-get upgrade if you are running Backtrack R3. Because backtrack is a utility OS, and not where you are doing your main work, you should leave it stock to avoid update conflicts. Every time I try and update backtrack, it always breaks things. Just use it as is. –  spuder Jul 31 '13 at 21:41
    
@spuder sorry but the reason I am asking the question particularly apt-get is because the stock doesn't work! –  cmd Jul 31 '13 at 21:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.