Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I started having issues after I programatically changed quite a few windows 7 settings. I thought I had reversed everything, but apparently something stuck. I can connect to the network, but it switches between saying I have internet, I am connected but don't have internet, and occasionally disconnecting and reconnecting me. In the browser, page loads just hang until they fail with a "change in network connection" or DNS lookup failiure.

Initially, I thought it would just be something simple. After a few hours of fruitlessly messing with various network related settings, I started to get a little more desperate; here are some things I have tried:

  • Used a system restore point from a few days ago

  • Restarted router

  • Reinstalled wireless card drivers

  • Deleted all network profiles and added the network from scratch

Even more interestingly, I can use every other wifi network to access the internet other than this one, so my wireless card isn't fried. To top it off, it's impossible to access webpages through the browser on this network, but when I just send requests over and over again through Python, about one in ten actually succeed.

My best guess is that it has to do with this network rejecting requests with a certain number of packet errors, but I have no idea how I'd go about fixing this. Many thanks in advance to anyone who can help me out.

share|improve this question
    
Have you checked your dns settings? Have you tried changing your dns to google ? 8.8.8.8 and 8.8.4.4 –  spuder Jul 31 '13 at 21:23
    
@spuder Just changed the IPv4 to those and it looked very promising. Skype managed to connect and I loaded a webpage, but then it went back to the same old connecting and reconnecting. Are there any public DNS servers like that for IPv6? –  Dan Dobint Jul 31 '13 at 21:41
    
You could also use the google ipv6 dns servers. However most internet providers still don't offer ipv6 (except though ipv6 to ipv4 tunneling) Those servers are here developers.google.com/speed/public-dns/docs/using –  spuder Jul 31 '13 at 21:43
    
No dice using those either. Any other possible solutions? I just don't want to have to reinstall the OS. –  Dan Dobint Jul 31 '13 at 21:44
    
Can you take ipv6 out of the equation and just use ipv4? –  spuder Jul 31 '13 at 21:45

3 Answers 3

Your Windows setup seems very loused up and I don't think we can find out what's wrong without some hands-on.

My suggestions are :

  1. Try going to an earlier restore-point than the one you used.

  2. Try sfc /scannow.

  3. Do Repair Install to Fix Windows 7.
    This is a soft re-installation of Windows, basically an in-place upgrade that will refresh Windows while preserving your user-accounts, data, programs, and system drivers.

If none of these works, you might have to bite the bullet and do a full reinstall.

Take good backups before starting and ensure you can reinstall all your installed products (installation media and serial numbers).

share|improve this answer
    
I should have read the question more carefully, my mistake. –  Moses Aug 9 '13 at 18:12

This sounds more like a race condition try;

  1. Go to your Event Viewer (Start > Control Panel > Administrative Tools > Event Viewer)

  2. Once in the Event Viewer, Click on (Windows Logs > System )

  3. Scroll down until you see any events pertaining to your issue.

Likely you'll see what the problem is right away. This sounds like you could have a hostname conflict; is there another computer on your network with the same name? If so, you will need to change your Computer Name to something different and that can be done in System Properties

If the event viewer is displaying something different post what the error is, and I'm sure you'll get the help you need.

share|improve this answer

I know you have probably tried this, but possibly the reason is because the ip address is set to a static value rather than being assigned automatically.

Try deleting the ip address as follows:

  1. Go to wireless network properties (Right click network > Status > Properties)
  2. Click on Internet Protocol Version 4 or 6.
  3. Click properties.
  4. Make sure that they are both set to obtain IP Address automatically.
share|improve this answer
1  
System restore rollback should have fixed that. –  harrymc Aug 10 '13 at 14:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.