Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My laptop's monitor does not work any more and thus I've attached an external monitor.

On boot, GDM still recognizes the primary laptop screen and displays it's login window on it. Which I then can't see.

I can disable the laptop's screen by running xrandr --output LVDS1 --off after logging in. I tried putting this command into ~\.xinitrc and into a ./40-xrandr.sh in /etc/X11/xinit/xinitrc.d.

Both to no effect at all. I had hoped that it'd at least would switch off the laptop's screen on log in.

How do I disable the laptop's screen before GDM starts?

share|improve this question
    
The BIOS might have an option to set the default monitor. A lot of the modern laptop BIOSes have this. Check your BIOS manual. When set correctly and your second monitor is plugged in, the BIOS will treat it as the primary (your OS will think this is the main screen), otherwise it will fall back to the laptop screen. –  ADTC Aug 1 '13 at 7:41
    
I looked for it, but the BIOS does not provide such an option. –  phw Aug 1 '13 at 9:06
    
No BIOS setting with the options like Internal LCD and External? Well, I'm sorry then. It would have been the simplest solution. –  ADTC Aug 1 '13 at 9:18
    
Yes, I know. I hoped for that too. And it's even a 'business system' (Dell Latitude D830) ... –  phw Aug 1 '13 at 10:04
    
Does this match your BIOS screen? I see a Video option on the left. It appears to have sub-options (as indicated by the +). What are the options available under Video? There are so much variations in BIOSes that one can't pinpoint exactly what option to use unless one looks at it. And the terminologies/descriptions used by the manufacturer are quite often inadequate, confusing or misleading. –  ADTC Aug 1 '13 at 10:32
show 1 more comment

2 Answers

modify /etc/default/grub and add

video=LVDS-1:d video=VGA-1:e

:d disable :e enable.

For example mine is

GRUB_CMDLINE_LINUX_DEFAULT="video=LVDS-1:d video=VGA-1:e acpi=force elevator=noop i8042.noloop=1 usbhid.quirks=0xeef:0x1:0x40"acpi=force elevator=noop i8042.noloop=1 usbhid.quirks=0xeef:0x1:0x40"

Hope this helps

share|improve this answer
    
Although this should work, it didn't in combination with GDM3. Thanks for the hint. –  phw Aug 2 '13 at 12:56
add comment
up vote 1 down vote accepted

Unfortunately, Halox answer didn't fix the issue, as GDM3 configures the X server on it's own and re-enables the disabled monitor (silly).

After reading the docs I added xrandr --output LVDS1 --off at the top of /etc/gdm/Init/Default and finally got it to work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.