Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have multiple email accounts properly setup in Outlook 2013 (can send/receive fine otherwise). Lets say they are:

user1@domain1.com
user2@domain2.com
user3@domain3.com

All belong to me and I have 3 separate SMIME certificates for these, installed into the Windows Certificate Store.

I even have 3 separate profiles in Outlook 2013 in the "Settings" section (via File => Options => Trust Center => Trust Center Settings => E-mail Security).

Issue: Outlook 2013 selects the last profile as the "Default setting" (say user3@domain3.com) and then applies this to all emails I send out, even from user1@domain1.com and user2@domain2.com !!! This is ridiculous!

Required: Obviously, When I send an email from my

  • user1@domain1.com account, I want certificates from user1@domain1.com to apply.
  • user2@domain2.com account, I want certificates from user2@domain2.com to apply
  • user3@domain3.com account, I want certificates from user3@domain3.com to apply

Question: How can I tell Outlook 2013 to properly map these accounts => SMIME settings/certificate relationships?

There is also a posting on two of MSFT's message boards, but the moderators are being lazy by asking the poster to message on the "other" message board. The actual issues was addressed on neither (!).

share|improve this question
add comment

1 Answer

I just found the answer for this:

File > Options > Trust Center > Trust Center Settings > E-mail Security > Settings

Create a new "Security Settings Name" for each of your certificates. When you send a signed or encrypted mail, just make sure the certificate selection is set on "automatic" in:

Properties > Security Settings

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.