Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently I've noticed that Adblock Plus doesn't block Google ads anymore. The page is just full of ads. Here's a query for "SSL" with Adblock Plus turned on.

I would like to not see Google ads in my browser. How do I get the previous behavior back?

enter image description here

share|improve this question

3 Answers 3

up vote 9 down vote accepted

As @djfdat already said: You have to disable "Acceptable Ads".
This setting is enabled by default!

enter image description here

This has nothing to do with your Google query for SSL or SSH. It's just that all Google websites are in the "Acceptable Ads" whitelist.

Story behind

Google (and other big companies) were asked to pay money by a firm called EYEO GmbH to show their ads. This firm owns Adblock Plus together with its main developer Wladimir Palant. And big player firms like Google accepted their offering.

Wait, they pay? Yes. This was a big story on the net the last couple of weeks when a blogger revealed the mafia-like system of Adblock Plus. Read more on Techcrunch.

Key statement on techcrunch

AdblockPlus says this fee is about helping it to maintain its filter list, which also whitelists some small websites and blogs for free, in addition to charging those larger companies like Google that participate. But it’s easy to see Google and others buying the right to put ads in front of web-browsing users, with Adblock Plus essentially acting as a gatekeeper meting out access to that sizeable chunk of consumers. Which gives Adblock a lot of power, and companies like Google that can pay a sizeable advantage over mid-sized competitors who can’t.

The Adblock Plus company blackmail websites in that way: "If you don't pay us, we block all your advertisements. We have 50 mio. users and the power to ruin you." The techchrunch article doesn't go into details, but the blog articles linked above do. They fake user reviews, even whole websites, conspire with big ad firms to white-list them and block those who doesn't pay. Thats criminal and I recommend you not to use this plugin aynmore in any browser.

Long story short: Use an alternative like Adblock or Adblock Edge. As far as I can remember they are both forks of Adblock Plus but without the "Acceptable ads" option.

share|improve this answer
Isn't it more like "please ensure your ads are non-intrusive and we will allow you subject to user agreement"? –  ADTC Aug 1 '13 at 7:09

In your Adblock Plus Options > Filter Lists, make sure you're subscribed to Easylist. Also, turn off the last checkbox on that tab for 'Allow some non-intrusive advertising'.

share|improve this answer

I just modified the "Acceptable Ads" list.

Actually, I deactivated Adblock Plus's list in the preferences, then I downloaded the source text file (you can find the link in the prefs dialogue) and removed all lines that I didn't like (Google and Amazon).

For Google I removed all lines (with some JavaScript) that satisfied the regular expression:


Then I added the new filter list and, lo and behold, Google ads disappeared again.

Since I wrote a script for that task, I can do that again at any time. It's some work, but for me it's the best solution, because I still have all "non-intrusive" ads white-listed except that from Google and Amazon.

I added the filters via a filter file I put on my own local server, so I could subscribe to my own list. But, I think, you can also add the filters manually.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.