Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is mostly an aesthetic issue for me, it has little functional impact.

Since the latest TextWrangler update (4.5.3), the new doc title's number seems to be incrementing persistently. Even after disabling Reopen Unsaved Documents and restarting, I'm up to "Untitled text 46" when I open the app.

I can't find any file cache, and no clue where else to start. Has anyone else encountered this? Any ideas on how to solve?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

I've had the same problem after updating to 4.5.3. The "untitled text" counter appears to be stored in: ~/Library/Preferences/com.barebones.textwrangler.PreferenceData/ in a file called Sleep State-*.appstate. (This file is created when you exit TextWrangler, so if TextWrangler is open, you won't see it.)

To reset your untitled text counter:

  1. Exit TextWrangler
  2. Move Sleep State-*.appstate to your desktop
  3. Re-launch TextWrangler

Now you should start seeing "untitled text 2" again. As far as I can tell, you have to do this every time you want to reset the counter. However, if you disable "Reopen documents that were open at last quit" in TextWrangler > Preferences > Application, you should get a fresh counter every time.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.