Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to use a specific version of java plugin in firefox to use VPN software.

I would prefer not to change the default version of java as that would affect other users of the system. To further complicate things I am working on a 64 bit ubuntu 12.04 with 64 bit oracle java installed using webupd8 PPA and I need to use 32 bit java plugin.

I have downloaded a java jre from oracle and installed it in my home directory. I have then symbolically linked libnpjp2.so from it into ~/.mozilla/plugins. Unfortunately this didn't help as I still get the system wide 64 bit jdk 7 and not the 32 bit version.

I used about:plugins and http://www.java.com/en/download/testjava.jsp to check java plugin version.

Any ideas on how to proceed from here?

share|improve this question

You can try this link for information on how to do this:

http://askubuntu.com/questions/128566/installing-multiple-jdk-versions-ubuntu-11-0

Then to get Firefox to use it use this snippet:

JAVA_HOME=/usr/lib/jvm/jdk1.7.0
MOZILLA_HOME=~/.mozilla
mkdir $MOZILLA_HOME/plugins
ln -s $JAVA_HOME/jre/lib/i386/libnpjp2.so $MOZILLA_HOME/plugins

Substitute the $JAVA_HOME part with your JDK location and $MOZILLA_HOME with your Firefox user config location. This replaces step 5 in the linked page.

share|improve this answer
1  
That is exactly what the OP tried which failed. He placed the plugin in his ~/.mozilla/plugins directory but still got the system wide one. – terdon Aug 1 '13 at 16:16
    
You are right. This is exactly what I have done sans setting up environment variables. – Dalibor Novak Aug 2 '13 at 8:48
    
You are right but after rereading his question the answer became obvious. You can't run 32 bit plugins on 64 bit Chrome. – krowe Aug 2 '13 at 15:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .