Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On Fedora 19, when I run xmodmap ~/.Xmodmap it locks my display for about 15-20 seconds. The command completes successfully, but I am unsure of why it takes so long. I'm assuming there is an X module that has to be reloaded, or something like that.

Is there a way to make it faster?

share|improve this question
    
I assume you are using Linux? – terdon Aug 1 '13 at 15:28
1  
How large is your .Xmodmap file? Can you run time xmodmap ~/.Xmodmap and also strace -f -tt xmodmap ~/.Xmodmap? – Etan Reisner Aug 1 '13 at 15:33
    
@terdon Yes, Linux. Fedora 19. Updated the post with that info. – mwcz Aug 1 '13 at 15:58
    
@EtanReisner 248 lines. I have tried time but it reports 0.02s. That's what makes me think there is some part of X that is consuming most of the run-time. strace reports approximately 0.02s as well. – mwcz Aug 1 '13 at 16:02
    
Can you post the output from those commands? Also what do you mean exactly when you say your display locks up? – Etan Reisner Aug 1 '13 at 16:06

You must log in to answer this question.

Browse other questions tagged .