Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've upgraded my machine to Windows 7 Professional (x64) (using format + clean install, not upgrade install).

Everything seems to work fine except for Ventrilo. I used to have Vista Business x64 and Ventrilo worked fine there, on the same machine.

The issue I am having is that when I am playing a game and using Ventrilo, everything works fine at first, but after a few minutes, I stop hearing anything that people say.

If I minimize, I can see the speaker icons lighting up (meaning that people are talking), but I still can't hear anything. The sounds from the game and other OS sounds still play through the speakers just fine.

Eventually, I will close ventrilo and then after a few seconds I will start hearing things that people were saying several minutes ago. I start hearing everything that was said, with no "silent time" in between. Note that the sounds keep playing even AFTER the ventrilo process is dead.

I've tried using Ventrilo x64 and x86 versions.

Does anyone have any advice on how to fix this problem?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

I was able to fix this issue by going into the Ventrilo setup options and checking Use Direct Sound.

alt text

share|improve this answer

It appears to be a known issue but no solution has been posted yet.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.