Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using "Cisco AnyConnect Secure Mobility Client v3.1.04059" to establish a VPN connection to a campus network at a university.
When I start the VPN client (vpnui.exe) I receive the following error message:

VPN service not available.
The VPN agent service is not responding. Please restart this application after a minute.

However, when I try to start the required service - called "Cisco AnyConnect Secure Mobility Agent"- manually (using admin privileges) I get this error:

Windows could not start the Cisco AnyConnect Secure Mobility Agent service on Local Computer. Error 1067: The process terminated unexpectedly.

I get the same error when trying to start the service over an admin command prompt (net start "Cisco AnyConnect Secure Mobility Agent").

I have uninstalled and reinstalled the VPN client several times, which didn't help.

The problem first appeared when an auto-update to the latest version of Cisco AnyConnect was performed (which is not optional, but happens automatically every time the vpn client is started, so going back to the previous version does not work...).

How can solve this issue? What am I missing?

EDIT: I have uninstalled my avast antivirus software now and deactivated windows firewall. To my surprise the problem is still there, so it is not related to Avast antivir as I thought at the beginning.

share|improve this question
1  
I can't help you with Avast, but I would suggest you look at Microsoft Security Essentials, which is free. windows.microsoft.com/en-CA/windows/… –  Xavierjazz Aug 1 '13 at 23:29
    
Thanks, but switching to another antivir software should only be a last resort solution at the moment. –  damage Aug 1 '13 at 23:32
    
Did you happen to solve this problem? I'm having the same issue. –  Chriszuma Sep 24 '13 at 22:13
    
Nope, but I found that the problem is related to the latest version of Cisco Anyconnect only, which can not be avoided due to automatic updating... My "solution" was to switch to ordinary Cisco VPN Client (fortunately I still had the required certificate). The antivirus software was not the issue in the end, since the VPN did still not work even after uninstalling avira... –  damage Sep 25 '13 at 20:06
add comment

1 Answer

well I have a fix for you, but its not 100% but it will get it working.

Control Panel > Administrative Tools > Services Right Click Cisco AnyConnect Secure Mobility Agent and choose start. Then run the client and connect

The root of the problem is its not respecting automatic start-up in Windows 8 cause the TCP/IP connector is handled differently in Windows 8 to get windows to start up faster. So upon start and coming out of sleep, it reverts back to stopped again. So upon every start-up you have to do this.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.