Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So my problem is this:

I have a Asus RT-N66U which is connected to WAN through my ISP.

I have my laptop running Windows 8 connected via WiFi to the router. According to IPConfig it has the following network stats:


Subnet mask:


This laptop is also connected to a gigabit switch via ethernet which is also connected to a server running XenServer.

I'm using Internet Connection Sharing to share the WiFi with my XenServer. With ICS enabled, I have the IP Address and the same subnet mask. Ipconfig has no default gateway listed.

My XenServer has the following network settings:


Subnet mask:


My problem is I can't figure out how to set up a static route so that other computers connected to WiFi through the router can access the XenServer. I'm fairly new to networking so I'm sure this is just inexperience on my part.

Any assistance would be appreciated.

Edit: Note that I'm not using a network bridge because ever since I updated my network drivers, it says that the network bridge does not have a valid ip configuration and neither my server nor my laptop would be able to connect to the internet.

share|improve this question
Try setting a static route on machines that require that access like this: route add mask metric 1. But that won't necessarily help as maybe the return route will have to be set too. The better option is to go with NAT somehow – Ashtray Aug 2 '13 at 7:54
Windows 8 Pro doesn't support NAT, and neither does my router unfortunately. I've only got the ability to set up static routing on my router or on my computers – Phillip Huff Aug 2 '13 at 13:40
@Alex I tried doing your suggestion, but I still get a "Request Timed Out" on PING. Firewalls on both my Windows 8 laptop and XenServer are off for testing and no luck. – Phillip Huff Aug 2 '13 at 13:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.