Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

By default, the firewall is turned on on all my workstations. I want to disable it. That works just fine.

However, if Windows thinks there is a change in the Network Location, the "Set Network Location" dialog appears. At that point my Firewall is still disabled. When my users click on any of the three options "Work", "Home" or "Public", Windows immediately changes the firewall settings and turns it back on.

Is it possible to stop Windows 7 from automatically turning the firewall back on when you change the Network Location? If yes, how could I perform this task?

share|improve this question
    
If you stop the Windows firewall service, does it do the same? –  Jesper Jensen Aug 2 '13 at 14:38
    
Are/can you use group policy to define the network Firewall policies? –  Ƭᴇcʜιᴇ007 Aug 2 '13 at 14:43
    
@JesperJensen I'm trying that now. But if my machine restarts, will it auto-restart? –  YpeDeg Aug 2 '13 at 14:54
    
@techie007 Which Group Policy objects would you suggest I have to change to affect the Firewall's properties? –  YpeDeg Aug 2 '13 at 14:55
    
@JesperJensen Disabling or stopping the service is not the right way to do it I'm afraid. The quality of communication is affected by this action. But thanks for your help. –  YpeDeg Aug 2 '13 at 15:05

1 Answer 1

up vote 2 down vote accepted

First, just disabling the Firewall service doesn't do it, as all traffic will be stopped if you do that.

Assuming that group policy is not being used to control the Firewall settings and/or service state...

How to permanently disable the Window 7 Firewall:

Disabling it via the Command Prompt:

  1. Open command prompt by right clicking on the shortcut and selecting Run as administrator. Accept any UAC dialogs that occur.
  2. Open windows services and make sure the Windows Firewall is started. The command will not execute if the firewall is off.
  3. Next type in the command: Netsh advfirewall set allprofiles state off
  4. Command prompt displays "ok." once it is successful.
  5. Reboot.

Disabling it via the GUI:

  1. Open Administrative Tools
  2. Open Windows Firewall With Advanced Security
  3. Right click on "Windows Firewall with Advanced Security on Local Computer" and select properties
  4. For each Domain Profile, Public Profile and Private Profile, set Firewall State to "off"
  5. Apply and close. Reboot the computer

Source for steps

share|improve this answer
    
Thank you very much! That is the solution I was looking for. –  YpeDeg Aug 2 '13 at 15:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.