Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using 3 years old overheating laptop and I want my CPU fan to be spinning 24/7 regardless of the consequences. How to make it spin?

The problem is that CPU & GPU heats up to 68°C (154 F) right after boot and never goes down, because CPU fan is not spinning full throttle. It starts spinning faster when temperature goes over 70°C and stops when it reaches seventy again. When doing heavy work on databases, it gets from 70 to 90 in no-time and automatically powers off. Bios does not contain any "fan spin 100%" options, just "spin slowly all the time" and "auto" which is more useless than the first one since my fan doesn't have pwm wire.

Currently I'm solving this with cooling stand (3x5V), but it isn't much of a help. I would rather use the CPU fan since it is the only fan directly responsible for cooling down CPU/GPU.

But how to make it spin 100% all the time? Should I attach it's red power wire to motherboard to get constant 5V (is there such option?), or is there an option to control it via software?

  • Laptop: Samsung R528 2.3 GHz Intel i3 with Nvidia GeForce 310M
  • Bios: Phoenix 03KT.M003.20100622.KSJ (and that is latest update)
  • OS: Ubuntu 12.04.2 LTS with 3.2.0.51 kernel
  • CPU fan: Image/Description Has 5V 0,4A and only 3 pins, no pwm.

P.S. Yes, I did clean everything with alcohol, freed the air vents, changed thermal paste etc; that reduced temperature by 4 degrees.

P.P.S. Some outputs:

share|improve this question
1  
a lot of the time, the BIOS ACPI will overrule any client programs, so if all else fails, look into CPU frequency scaling, to reduce the CPU clock speed when it gets hot. that (and a horkin cooling plate) was the only solution I was able to find with my HP laptop and ubuntu. HP support was useless since they did not support linux. –  Frank Thomas Aug 2 '13 at 15:58
    
@FrankThomas My CPU is already working "on-demand" - small freq when idle and bigger when intense. This saves me some degrees, so good advice. :) –  Gundars Mēness Aug 2 '13 at 16:22
    
Before going to something that drastic, I'd recommend opening the case and using a can of compressed air to blow out the dirt and hair that's collected in there. Most likely that's why it's overheating, and it's probably got the fan all gummed up. –  Taegost Aug 6 '13 at 13:29
    
Maybe your BIOS has settings for controlling min/max fan speed. See also this link. –  harrymc Aug 6 '13 at 15:25
    
@harrymc Be more careful, OP: "Bios does not contain any "fan spin 100%" options, just "spin slowly all the time" and "auto" which is more useless than the first one" –  Gundars Mēness Aug 6 '13 at 16:07

3 Answers 3

You are running Ubuntu so the normal suggestion of Speedfan is out, but you can look into two software packages, the first is called lm-sensors which provides with the temp sensors and fancontrol which gives you the ability to control your fan activation ranges. I am not a native Ubuntu user but if you Google those two you can find tutorials on how to install and setup the applications. Hopefully this helps.

share|improve this answer
    
Tried it, pwmconfig says "/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed" and fancontrol therefore doesn't start. –  Gundars Mēness Aug 2 '13 at 16:20
    
I was worried that would be an issue, without a PWM control, you may not be able to do much more than you already have available. This could be why your BIOS is also lacking anything but the most basic fan controls. At this point you might look into a replacement fan with 3pins and PWM. You can get PWM control with a 3pin fan, just whether you can find one to fit your case is the big stickler. –  enigma7767 Aug 2 '13 at 16:31
    
@GundarsMēness You should read this answer on AskUbuntu askubuntu.com/q/281478/169736 –  Braiam Aug 5 '13 at 15:04
    
@Braiam You should read that I'm not using a Dell laptop :) –  Gundars Mēness Aug 5 '13 at 15:09
    
@GundarsMēness the method looks pretty canonical to me, since you don't have your modules loaded, you should have run sensors-detect first, then pwmconfig. But if you don't want the mention of "Dell", check this one askubuntu.com/a/46135/169736 is almost the same –  Braiam Aug 5 '13 at 15:12

Brute force solution would be to snip the power cable from fan's connector and solder it to +5V pin on one of the USB ports. The other two pins(tacho and ground) should stay connected to fan header so you can monitor RPM of fan and BIOS will not freak out thinking the fan has stopped working.

Caution:

  • Damage IS possible if cables are misswired.

  • If the USB port from which +5V is drawn is configured to be powered while laptop is turned off the fan will always be on

  • Cut the cable long away from connector so it is possible to undo this hack if software solution is found

  • The amount of power available from USB port piggybacked is now limited, possibly on other one if it shares the same internal hub/power lane.

  • Use this solution as last resort

share|improve this answer
1  
Thanks for editing jonsca; I should spell-check and reread after typing :) –  nomen_n Aug 6 '13 at 0:09

I had same problem with HP dv6, changing power settings in windows did the trick but on ubuntu, there is not any option for that.

Try installing Jupiter:

Its the only tool to address overheating issue on ubuntu.

sudo add-apt-repository ppa:jolicloud-team/ppa
sudo apt-get update
sudo apt-get install jupiter

more info : http://itsfoss.com/install-jupiter-ubuntu-1304/

TIP : Next time buy ubuntu certified machines.

share|improve this answer
    
"Ubuntu certified machines"? Don't get me wrong, but no machine can every be truly certified for that thing. Anyway, Jupiter crashed. –  Gundars Mēness Aug 11 '13 at 18:49
    
yeah but atleast they include some power management stuff. Do you have hybrid graphic card in your laptop ? –  johnny Aug 11 '13 at 18:53
    
Google intel switchable graphics for ubuntu if you have hybrid card. –  johnny Aug 11 '13 at 18:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.