Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a ASUS O!Play HD media center hard-drive thingie. It has a 2TB hard drive which is formatted in NTFS, and runs some version of linux.

The UI for this thing is awful, and every time I turn it on I have to navigate through endless trees to find the show I was watching yesterday and continue. Since I can't hack a "recently played" menu in there and I don't want to go rearranging the very neat file structure, I've decided I can resolve the issue with symlinks

I used mklink commands and tried the following

  • Symbolic Link /D - worked, but the oplay shows the folder as empty
  • Hard Link /H - access denied
  • Directory Junction /J - worked, but the oplay shows the folder as empty

Can anyone help?

share|improve this question
    
Does the links not show only on Linux, or on Windows as well ? –  Levans Aug 2 '13 at 18:29
    
On windows the folders work as expected and are full of files. Under linux, the folders appear but are empty. –  roryok Aug 2 '13 at 18:38
add comment

1 Answer

The widely used Linux driver ntfs-3g does not handle yet symbolic links on NTFS partitions.

You may give a try to NTFS-3G Advanced, more or less a development version, which claims allowing NTFS junction points and symbolic links to be seen as Linux symbolic links.

Still be careful, there are less guaranties of stability than in the main branch of ntfs-3g.

share|improve this answer
    
I don't think you entirely understood the question. My only input on the media centre is through the remote control. I don't know what driver it uses for NTFS but I certainly can't change it. If I can't make this work through windows or through another PC using linux, I can't make it work –  roryok Aug 2 '13 at 19:06
    
@roryok well, if you cannot access your O!Play to install drivers or so, I doubt you'll be able to have it see NTFS symbolic links, sorry. –  Levans Aug 2 '13 at 19:15
    
If I was to create the symbolic links from a linux machine, would that make any difference? –  roryok Oct 11 '13 at 9:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.