Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

enter image description here

I was trying to install itunes on windows 7, 64 bit, i got that error. the solution i found is to install VC++ runtime, i tried installing 2005 and 2008, got that same error, tried installing 2012, it said not a valid win32 program or something like that.

I tried installing .net framework 4.5, didn't fix it. I saw this question. I see nothing in the Turn Windows features on or off section and i tried installing without .net framework and with it, no difference, the presence or absence of the framework doesn't make any difference, the laptop didn't have .net framework before, i got this error, installed it to see what happens, the error is still the same.

Another solution is to use Microsoft fix it, but didn't fix it :)

Note that earlier today i had this problem on the same laptop, fixed that, now i have this, maybe they are related, i don't know.

I see no such thing as Windows Module Installer

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The error means ERROR_SERVICE_DISABLED

C:\Users\André>err 0x80070422
# as an HRESULT: Severity: FAILURE (1), FACILITY_WIN32 (0x7), Code 0x422
# for hex 0x422 / decimal 1058
  ERROR_SERVICE_DISABLED                                         winerror.h
# The service cannot be started, either because it is
# disabled or because it has no enabled devices associated
# with it.
# 1 matches found for "0x80070422"

start services.msc and make sure the service Windows Modules Installer is NOT disabled.

share|improve this answer
    
i forgot to mention, i saw that solution, but there's no such thing as Windows Module Installer –  Lynob Aug 2 '13 at 20:00
    
the name is Windows Modules Installer: dl.dropboxusercontent.com/u/5749744/Bilder/superuser/… –  magicandre1981 Aug 2 '13 at 20:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.