Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I set up a sage server by adding the following line to my ~/.profile:

nohup sage -c "notebook(interface='', secure=True, automatic_login=False, directory='./sage_notebook.sagenb')" >/dev/null 2>&1 &

I run my sage server from an Ubuntu desktop.

When I login and try to plot graphics from my laptop, the figures appear on my desktop screen.

I tried looking for solutions to this online, but I could not find anything.

share|improve this question

migrated from stackoverflow.com Aug 2 '13 at 21:09

This question came from our site for professional and enthusiast programmers.

    
this might do better on super user as this is really a system configuration issue, not a programming issue. – tcaswell Aug 2 '13 at 16:07

It turns out that this was caused by setting SAGE_PATH to python's site-packages.

In hindsight, I realize this probably overwrote Sage's built in graphics libraries and caused the graphs to be plotted from the computer that started sage.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .