Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded from KDE 3.5 to KDE 4, and I have been having weird issues with my keyboard. In one of the virtual consoles e.g. when I press ctrl + alt 1 , I can type perfectly, but in KDE, several of the number keys don't work, the left and right arrows don't work either.

When I press the right arrow key in xev I get this:

KeyRelease event, serial 34, synthetic NO, window 0x3600001,
root 0x6f, subw 0x0, time 903459, (111,55), root:(115,836),
state 0x10, keycode 114 (keysym 0x1008ff11, XF86AudioLowerVolume), same_screen YES,                                                                         
XLookupString gives 0 bytes:                                                
XFilterEvent returns: False

When I press the '3' key it toggles my Bookmarks toolbar in Firefox, in xev I get this:

KeyPress event, serial 34, synthetic NO, window 0x3600001,
root 0x6f, subw 0x0, time 999968, (94,115), root:(98,896),
state 0x10, keycode 12 (keysym 0x1008ff30, XF86Favorites), same_screen YES,
XLookupString gives 0 bytes:                                               
XmbLookupString gives 0 bytes:                                             
XFilterEvent returns: False                                                

KeyRelease event, serial 34, synthetic NO, window 0x3600001,
root 0x6f, subw 0x0, time 1000032, (94,115), root:(98,896),
state 0x10, keycode 12 (keysym 0x1008ff30, XF86Favorites), same_screen YES,
XLookupString gives 0 bytes:                                               
XFilterEvent returns: False

As this is deeper down, changing the type of keyboard in the KDE meun's has no effect. I'm slowly beginning to wade through the mountains of documentation about the X keyboard model, but there has to be a better way. Does anyone no what it is?

Edit:

1234567890 ! after deleting the entire .kde folder.

but only until I change the Keyboard settings from the "system settings" applet, then its hosed full time. Regardless of what I set the settings too. (restore to default settings doesn't)

2nd Edit:

I'm using Gentoo AMD64, I was upgrading from KDE 3.5 > KDE 4.2.
I think I had manual settings before, although I didn't change anything. I was originally running KDE without HAL until that stop working a year or so ago. The only customisation I made was to set the multimedia keys to control Amarok.

3rd Edit

   $ grep xkb /var/log/Xorg.0.log
   (**) Option "xkb_rules" "evdev"
   (**) Option "xkb_model" "evdev"
   (**) Option "xkb_layout" "us"
   (**) Option "xkb_rules" "evdev"
   (**) Option "xkb_model" "evdev"
   (**) Option "xkb_layout" "us"

Xorg.0.log has this to say:

(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse1
(WW) Disabling Keyboard1

My Xorg.conf has this in it.

    Identifier  "Keyboard1"
    Driver      "kbd"
    Option      "AutoRepeat" "500 30"
    # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
    Option      "XkbRules" "xorg"
    Option      "XkbModel" "pc105"
    Option      "XkbLayout" "gb"
share|improve this question

5 Answers 5

up vote 1 down vote accepted
+100

Perhaps you could:

  1. Move these files from ~/.kde/share/config/ .. kxkbrc , khotkeysrc , khotkeys_update , and startupconfigkeys to another location

Then let KDE run defaults on next start up and go re-config your lyaout settings.

When I went from KDE 3.5 to 4.2 I had to remove some old configs to resolve a few issues, not this specifically, but in other K apps. Beyond that, try a new keyboard, just for fun.

share|improve this answer
    
not bad, but instead of deleting them, move them to different locations, eg, rename them all to *.bak. if the OP customized functionality in the old config, it would be missing in KDE4's defaults, and having the old config around to compare might help get the functionality back. –  quack quixote Nov 5 '09 at 8:28
    
I moved the whole folder, but we are only half way there, see my edit. –  user4774 Nov 5 '09 at 19:44
    
Just curious here, what distro and KDE4 version are you using? –  SleighBoy Nov 5 '09 at 21:28
    
Also, are you using manual Xkb settings in your xorg.conf or doing it via HAL? –  SleighBoy Nov 5 '09 at 21:43
    
answers in question above. –  user4774 Nov 6 '09 at 10:16

First, create another user account, log in and test if keymap works there. If yes, then the problem is in your private configs. That will localize the problem whether it's system-wide (/etc, /usr/share/kde*) or user (~).

Next, open keyboard preferences, change something, and close it: you'll have some default configuration in the new home folder. After backing up your personal folder, try to move these files: that can help.

share|improve this answer

Virtual consoles (tty) are completely unrelated to X11 and use a different keyboard mapping mechanism. Did you try starting a different desktop (twm/icewm/gnome whatever)?

share|improve this answer
1  
True, but I need to prove that the 3,4,5 keys on my keyboard are not broken, jam in the switches etc. They work fine in the tty. –  user4774 Nov 2 '09 at 10:26

The 'state 0x10' implies that one of your modifier keys is stuck down. I'm on OSX, but that state corresponds to my command key, which I think is mapped to the logo key on PC keyboards. Try hitting the logo key a few times (or other modifiers, like alt or ctrl) until state returns to 0x00, and see if that makes a difference.

share|improve this answer
1  
I so wanted this to be true, I almost accepted the answer before I tried it out, but sadly it isn't right. 'state 0x10' refers to the fact my num lock key is pressed down. 5 & 6 (the top line) still don't work, sadly. –  user4774 Nov 4 '09 at 19:38

Inspired by o_O Tync answer; Posted in case anyone else has this same issue. I renamed my home directory as 'backup', removed my account, recreated it. Hacked passwd and groups so I have the same uid and gid, then moved all the visible files back. Then I copy other apps hidden files if I think I need them. Strangely it now works perfectly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.