Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I go about shrinking a non-boot drive? I've read through all of the questions on here and can't find a thread similar to mine. I have a 931.51GB NTFS partition (D:/), and I'm trying to Shrink it using the Windows Disk Management tool.

So, first off, it tells me that I can shrink up to 154.027GB. enter image description here

After I do this (I change the value to 100000 (100GB) instead, as that's what I want to shrink it by), I get an error after about 5 minutes: enter image description here

I guess I'm just not sure what to do at this point. I have a lot of data on there that I'd really like to not have to delete, but if I have to, then I have to. I'm trying to dual-boot Windows and Ubuntu (or Mint) and the automated installer is failing to resize my partitions - I came on windows to try it here, and I have the same exact problem - there's definitely something going on here.

Here is a picture of my current Disk Manager display: enter image description here

Things I've tried:

-chkdsk C: /f (found/fixed errors, still no luck) -chkdsk D: /f (found/fixed errors, still no luck)
-WinDirStat to see if there are any weird files, and I did not see any ( but I don't know the tool that well)
I also noticed that Windows says that D is the "primary" drive, even though it's installed on my SSD (C:/).

I appreciate any and all feedback. If by some chance this question WAS posted elsewhere, I apologize in advance and I'll be happy to remove.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

I would say Windows is just having a bad day. When all else fails do it yourself. Try to manually fix your problem: http://gparted.sourceforge.net/

This nifty program can shrink and move partitions when Mr. suborn Windows fails. gParted is linux only, but is included in Live Ubuntu CD's (Possibly Mint). (http://www.ubuntu.com/download/desktop)

Alternately you can download just gParted and boot from that. (http://gparted.sourceforge.net/livecd.php)

Here is a full tutorial: I recomend printing it before trying anything (http://www.howtogeek.com/howto/windows-vista/using-gparted-to-resize-your-windows-vista-partition/)

share|improve this answer
    
Thanks, Mark. I ended up formatting the entire drive, as I think there was just something weirdly wrong with it. There was a hidden MBR somewhere on my alternate drive, and that's what was causing the issues. I managed to get rid of it and things were fine. Thanks again for all of your help though, I appreciate it. +1 and marking your answer as best. –  Ricky Mutschlechner Aug 8 '13 at 14:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.