Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there a way of preventing mutt from assuming an address without an @ is an address on my local machine. This generally happens if I mistype a name from my address book.

If I type mispeltname I would like it to ask me to correct the address rather than sending to which will bounce.

share|improve this question
up vote 0 down vote accepted

You can prevent mutt from appending your local domain name to unqualified addresses with set nouse_domain. But, this won't cause any prompting for a correct address, it will only transfer the responsibility for qualifying the address to the first mail transfer agent that handles it.

There isn't currently an option to do what you're looking for. You may just want to get accustomed to looking over the addresses included on the compose screen before you tell mutt to actually send the message. Besides catching this type of error, that would also allow you to catch cases where you mistakenly did a group reply rather than replying just to the sender. And at that point you do have the opportunity to edit the recipients.

share|improve this answer
Thanks qqx. I suspected from Googling that there wasn't a way of doing exactly what I wanted, but nice to know for sure. I have some ideas for a workround - will investigate further. – justintime Aug 5 '13 at 12:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .