Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using Remote Desktop (from Windows 7 to Windows 7), the caret (the vertical bar indicating where text will be inserted) sometimes jumps back to the cursor position. This causes the text I'm typing to be garbled.

For instance, I'm typing this text over such a connection; the cursor is at the start of the sentence I'm typing. At any moment, the text caret may spontaneously jump back to the cursor position, as if I'd clicked there, while I'm just typing, causing the rest of what I type to be inserted at that point, instead of at the end of the sentence.

This is very annoying and the Remote Desktop help or Google don't give me any clues. (I don't know whether it only happens with Windows 7.)

Why is this happening? How to fix it?

share|improve this question
    
By chance, are you using a laptop? –  Bon Gart Aug 3 '13 at 14:06
    
Yes, I am. And it only appears to happen in full screen mode. –  reinierpost Aug 3 '13 at 21:50
    
It actually sounds like you are accidentally hottomg the touchpad with your hand while you are typing. Some newer laptops come with drivers that disable the touchpad while typing. –  Bon Gart Aug 4 '13 at 2:10
    
Typed that from the phone, and didn't read it first... "hottomg" is actually "hitting". What you described, is what I used to deal with constantly with my 2004 Toshiba A75. I had to learn to lift my hands when I type to keep from accidentally tapping the touchpad with my right thumb and redirecting the focus of my typing to wherever the I-bar was positioned. –  Bon Gart Aug 4 '13 at 20:07
    
Hmmm ... an interesting theory, I will check it, thanks! –  reinierpost Aug 5 '13 at 11:47

2 Answers 2

up vote 1 down vote accepted

It sounds like you are accidentally tapping the touchpad with your thumb or the heel of your hand. It's not uncommon, and it is actually apparently common enough of a problem that modern touchpad design has evolved to take it into account. Touchpad hardware companies have in recent years added the feature to disable the touchpad while the keyboard is in use. It doesn't appear to just be a function of software or the drivers, since it isn't a feature that can now be enabled on older hardware.

If you have the most recent mouse/touchpad drivers installed, you can check the mouse properties panel in control panel (or even the touchpad control running in the taskbar if present) to see if you can enable this feature. As in the thread you found, for the Dell Precision M4500, it is called "Hide pointer while typing". It could be called different things, depending on your particular make/model.

share|improve this answer

I would suggest that you move your cursor of both your PCs away from the typing space of your program/document while you are typing.
It seems like one of your PCs is generating a mouse click event automatically.

share|improve this answer
    
From any typing space, to be more exact. Yes, that's the workaround I'm trying to train myself to use now. What I want is a solution. –  reinierpost Aug 3 '13 at 21:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.