Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two Netgear wireless routers; one primary (WNR2000) connected to the Internet, and a secondary (WNR1000) connected to the primary via a long Ethernet cable to the other side of my home. A LAN port from the primary router is connected to the Internet port of the secondary router.

I set up the primary router's IP to 192.168.0.1 and its DHCP to give out IP address 192.168.0.2 to 127, and hard coded the secondary router to 192.168.0.2 and configured its DHCP to use the range 128 to 255.

I also set the secondary router's NAT filtering to "open" rather than secured.

The problem is when I try to access a Windows PC (A) that's connected on the primary router from another Windows PC (B) on the secondary router, computer B can't find computer A.

I had tried disabling DHCP altogether on the secondary router, but then new devices didn't get an IP address at all. It seems that the primary router won't serve up IP addresses on the second network for some reason.

What am I doing wrong?

share|improve this question

closed as off-topic by Daniel Beck Aug 4 '13 at 20:04

  • This question does not appear to be about computer software or computer hardware within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Closing this question upon user request: The actual issue was unrelated to the (possibly incomplete or incorrect) information provided in the question. –  Daniel Beck Aug 4 '13 at 20:04

3 Answers 3

  1. Turn off the DHCP service on the secondary router
  2. Plug the cable to any LAN port on the secondary router
  3. Now the secondary router will serve as a switch and all devices connected to it will get IP from the primary router
share|improve this answer
    
Hi whatUwant, you must not have noticed that in my question I mentioned that I already tried this. For some reason the primary router won't dole out addresses to clients on the secondary network. –  glenviewjeff Aug 3 '13 at 21:51
    
You may have tried it already, but I think this is more along the lines of what you need to do. Have you tried switching secondary router to Bridge mode? –  Rory Aug 3 '13 at 21:56
1  
Have you plugged the cable to a LAN port (not the WAN port)? –  whatUwant Aug 3 '13 at 22:09
    
My mistake; can you make a slight edit to your question so I can undo the downvote? Sorry about that. –  glenviewjeff Aug 3 '13 at 22:16
    
@Rory my secondary router doens't have a bridge mode. –  glenviewjeff Aug 3 '13 at 22:16
up vote 0 down vote accepted

It ends up there's no way anyone besides me could have solved this problem. It was my idiotic network topology. I had a Voip device inadvertently sitting between the two routers blocking the uplink traffic.

I would delete the question but it needs moderator approval because there are answers. Please feel free to vote to close.

By the way, this guide works well if you'd like to accomplish this successfully: http://www.speedguide.net/articles/how-to-set-a-wireless-router-as-an-access-point-2556

share|improve this answer

The secondary router should have an ethernet cable going into it's WAN/Internet port, which should be coming from a LAN port from your primary router. The secondary router should also be setup as Access Point only.

Most stock firmwares allow this already, but if yours doesn't, you can try a custom firmware (DD-WRT, OpenWRT, Gargoyle, Tomato, etc).

You can try to mess with the DHCP rules a bit to make the devices connected to the secondary router/AP to get IPs 128 to 255.

share|improve this answer
    
Hi Anit, you must not have noticed that I already set up the secondary router to use 128 to 255. I also already have an ethernet cable running from a LAN port of the primary to the Internet port of the secondary. The WNR1000 doesn't appear to have a setting for "access point only". –  glenviewjeff Aug 3 '13 at 21:44
    
well yeah but but setting the secondary router's IP address range implies that DHCP is still enabled, which it shouldn't be. I THINK that they're going on to different subnets. Computer B can't find A, but can computer A find B? –  Anit Gandhi Aug 3 '13 at 21:51
    
Anit, I had tried both methods. Disabling secondary router's DHCP prevented any IP address from being provided to clients on the secondary network. Enabling DHCP allows internet access at least but no communication between devices on the LAN. –  glenviewjeff Aug 3 '13 at 21:53
    
Anit, I don't think the computers can see each other in either direction. –  glenviewjeff Aug 3 '13 at 23:36
    
I know this is against what I said earlier and it doesn't sound logical to me, but have you tried/can you try plugging it in into a LAN port instead of a WAN port? Some Netgear page said to try that... –  Anit Gandhi Aug 3 '13 at 23:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.