Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to disable the Intel turbo boost on my Dell i5 laptop. Even for regular activity like starting the chrome or IE, turbo boost is starting and especially I am annoyed by the heat and fan noise it makes while it is starts turbo boost. Please help me out as it more nuisance rather than the performace boost.

share|improve this question
    
You should be able to do this while within BIOS. If there isn't an option this is one of those features that cannot be disabled from within an operating system. –  Ramhound Aug 4 '13 at 2:01
    
If possible can I have any link so that I can disable it –  Rap Aug 4 '13 at 2:02
2  
I don't have a link and the exact instructions would be specific to the motherboard. Have you simply tried booting into your BIOS and looking for the option to disable it? If your asking me to prove this is the solution I wouldn't do that even if there was a link. –  Ramhound Aug 4 '13 at 2:04
1  
Chances are good that even if "turbo boost" itself did not engage, the heat and the fans ramping up would still occur when the cpu (and/or gpu) goes to work. I would much rather have a laptop that the fans work a bit too hard, than to have a laptop that is overheating :-) –  Psycogeek Aug 4 '13 at 5:09

1 Answer 1

up vote 7 down vote accepted

Well, it’s relatively easy.

Go to Control Panel -> Hardware and Sound -> Power Options and click Change plan settings near your plan (e.g. I use High performance for CPU intensive tasks, such as gaming).

Then click on Change advanced power settings.

Scroll down to Processor power management and expand it.

Expand Maximum processor state and modify both On battery and Plugged in to 99%.

Then simply click Apply and OK.

Note:

Also please make sure, that Minimum processor state is not greater than Maximum processor state (in this case - 99%), because it won't wprk. I suggest you to set it to 5% or so.

And that’s it, no more Turbo Boost, no more overheating and if there is a need - these changes are very easy to revert. What you just did is created a limit, that prevents your laptop to go into such state, when Turbo Boost kicks in.

share|improve this answer
1  
Thanks. Made the changes and it looks okay as of now –  Rap Dec 4 '13 at 7:39
1  
Setting it to 99 % doesn't seem to disable Turbo Boost completely for me, 90 % does seem to work. –  svick Feb 5 at 15:18
    
i noticed that for some reason my Minimum processor state was at 100% causing turbo boost to bounce up and down crazy so i reset plan and everything seems ok now –  imanabidi Dec 7 at 18:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.