Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been using autohotkey on a terminal with 122 keys. I remapped the keys so that their original funky uses are now much closer to normal modern computers. I also mapped a scancode to Windows since the keyboard came without a windows key.

Sc076::lwin

This worked fine.

Now I am trying to create macros involving the use of this windows key.

eg

#1::
CoordMode, Mouse, Screen
MouseClick, Left, -1075, 700
CoordMode, Mouse, Relative
Return

#4::
Run http://my.ebay.com/ws/eBayISAPI.dll?MyEbay&gbh=1
return

The two above codes, windows-1 and windows-4, work perfectly with my other keyboards, including a Model F (ie older keyboard) and a very modern Cherry keyboard. (Note that I also created a windows key for the Model F since it comes without windows keys)

But I simply can't get these to work on my 122-key terminal. If I press #1 on my terminal, it either brings up nothing, or it brings up the windows menu and puts a 1 in the "search programs and files" field. My Model F and Cherry G80 are connected to the computer also and they can execute these macros fine.

Does anyone have a solution?

share|improve this question
    
So, you use Autohotkey to remap all keys, right? I guess if you instead use the registry (SharpKey = GUI for Registry remapping) for remapping, your second issue should be solved. –  nixda Aug 4 '13 at 7:42
    
Is SC076 & 1:: instead of #1 working? –  T-- Aug 4 '13 at 10:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.