Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a dual boot on my PC.
I can access Internet through Windows but cannot do it through Ubuntu.

I was able to connect to Internet on both OSses until some days ago, when my brother reset my router (or modem, I don't know) to factory settings and the Internet stopped working on both OSses.

After some tweaking the setting in the DSL setting page in Windows (192.168.1.1), it started working properly without having to connect manually through the network dialog.

But it still isn't working on Ubuntu 12.04. Additionally, I can't open the settings page from Ubuntu but in Windows it opens up perfectly.

In Ubuntu, I tried doing sudo pppoeconf, but it said that it cannot detect access concentrator on eth0.

Why am I able to connect to the Internet through Windows, but not Ubuntu? How can I resolve this?

share|improve this question
    
Try changing your default gateway –  notbad.jpeg Aug 4 '13 at 7:34
    
I didn't understand. Can you please elaborate the procedure(post as answer, maybe?) –  svineet Aug 4 '13 at 7:35
    
For Linux please post the output of ifconfig -a here. For Windows please post the output of ipconfig /all here. Please also post the vendor and model of your router here as well. Routers usually come with multiple network ports and a dhcp server that hands out IPs in the private address space 192.168.X.X. I suspect you don't need to configure pppoe settings because your router takes care of that for you. You only need to instruct Ubuntu to request a dhcp lease from the router's dhcp server. –  megamorf Aug 4 '13 at 8:10
    
delete the entry of your router from Edit connections and wait for a few seconds for the router to show up –  Franco Aug 4 '13 at 8:39
add comment

2 Answers 2

Your router is probably already managing the PPPoE connection. What you need to do on Ubuntu is to instruct it to get an IP address from the DHCP server.

  1. Edit /etc/network/interfaces. You may type sudo nano /etc/network/interfaces to open a text editor.

  2. Assuming your interface is eth0 as in most cases, verify that the following lines are present, or add them if they're not. Save the file and close it.

    auto eth0
    iface eth0 inet dhcp
    
  3. Enable the interface and trigger a DHCP discovery.

    sudo ifup eth0
    

Your router should then assign an IP to your machine along with a default gateway and a DNS server to reach outside networks.

share|improve this answer
add comment
up vote 0 down vote accepted

After some hit and trial, I understood that the router is handling my PPPoE connection.
All I had to do to restore the old condition was to -

  1. Open settings page from Windows
  2. Factory reset the router
  3. Edit PPPoE connection to make it 'Bridging' and leave all else untouched.
  4. And it works

I appreciate all other answers, but before I saw them, I had already done the above, So I'm sorry. But I have nevertheless upvoted all other answers.
Thanks for your effort.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.