Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.
  • I just purchased a ASUS Notebook N76V.
  • I first upgraded the OS to W8 Pro.
  • I activated the Hyper-V feature.
  • Everything runs fine. I can create virtual switches / Import VMs / Create new VMs / Boot my VMs.
  • I configured the IP addresses / Sub-masks / default gateway
  • I disabled my firewalls
  • Under Hyper-V all my network adapters seem to run OK
  • I've tried all the 3 types of Virtual Switches (Internal / External / Private)
  • I can never access my default gateway. The only thing I can ping is the VM itself.
  • I've created many virtual environments before, where my host machines were either a Windows Server 2012 or Windows Server 2008 R2. I've never had problems to access the default gateway and other WMs on the virtual network.
  • This is the first time I'm using Hyper-V on W8, and the first time I'm using the ASUS N76V Notebook.
  • Is there anything in particular I have. to configure?
share|improve this question

migrated from serverfault.com Aug 5 '13 at 0:07

This question came from our site for professional system and network administrators.

    
Describe your virtual switch configuration and your network hardware. –  Michael Hampton Aug 5 '13 at 0:13
add comment

1 Answer

Configure every virtual network adapter to the external setting. They will be bridged to a physical network interface and behave as if they were connected in the same device as your physical network adapter.

If you have a DHCP server, it will serve them IP addresses. If you don't, you need to configure static IP addresses in the same subnet as the default gateway you're talking about.

share|improve this answer
    
Thank you Greg, Yes with the external setting it seems to work. I'm able to ping all the VMs and my host as well. It is normal that I can't ping my default gateway (192.168.1.1)? It seems to me that I was able to do that in previous labs, when I had a 2012 as host and a private setting. –  user243531 Aug 6 '13 at 1:17
    
@Nakata please register your accounts on Server Fault and Super User. You will then automatically get access to your question back, and be able to edit the original question and reply to comments on the answers. –  nhinkle Aug 6 '13 at 3:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.