Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem is that I double-clicked on the OpenSUSE iso image and saw the graphical interface/installer. It said I should restart the computer.

I was going to install a dualboot on the brand new Windows 8 laptop. I didn't seem to get Ubuntu installed on the thing. The menus were very "dos-like" and when I tried "try before installing", only a black screen showed up. Same problem with opensuse eventually...

BUT... the problem is that after getting that black screen with OpenSUSE, it's still showing up at boot time 100% of the time! The interface looks Windows 8 styled (light blue background, squary UI) and has the options Windows 8 and OpenSUSE (LOCAL).

I tried deleting the iso image, but it didn't work. I also booted the computer and accessed the command prompt before Windows 8 started. I tried these: bootrec /fixmbr (and I got text that "it worked"). Didn't work at all. I also tried bootrec /rebuildbdc and with no luck... the waiting screen (5 seconds, 30 seconds or 5 minute waiting options) is still there.

I even went to msconfig in Windows 8 and only Windows 8 is listed. It seems that OpenSUSE (LOCAL) isn't even showing in any place except each and every time when I boot my computer.

Please help! :( And any idea why I just got a black screen when trying to install those distros? It's my company's laptop and I only use it at work so I don't have a lot of time to mess around with it besides working with it, so I hope there's a quick fix (not something like "reinstall windows 8"...). And I was going to do a dualboot because I need a linux server environment to test out stuff.

-CH

share|improve this question

1 Answer 1

Looks like OpenSUSE installed a boot loader which chains (loads) to the Windows boot loader. This is default on all Linux installations because Windows just doesn't like to share his toys (its bootloader).

Just run the Windows 8 installer disk and click "Repair Windows" when prompted. This should restore the default bootloader. (Or try Windows 8's new restore function: http://www.bleepingcomputer.com/tutorials/http-wwwbleepingcomputercom-tutorials-automatically-repair-windows-8-with-automatic-repair-/)

I would bet the black screens are from some form of Secure Boot which is on by default on any Windows 8 supported hardware. Secure boot was designed to prevent what you are trying to do now (if you were some malice guy trying to get into Windows). (http://technet.microsoft.com/en-us/library/hh824987.aspx)

I would avoid dual booting anything with Windows. Windows was teased as a smaller OS, and developed differently than all the other OS's. Windows does not like to follow any standard or convention and likes to do things his own way. Instead of dual booting use a Virtual machine (Vmware or Virtualbox) and install Linux to that. This will prevent any issues in the future. (https://www.virtualbox.org/)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.