Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Belkin N150 wireless router that, up until yesterday, was working smoothly. Unfortunately, it has done nothing but blink amber for the past day or so, and I need some assistance. It's connected to a Motorola SB5100 cable modem for RCN in NYC. The modem has had no issues, and works perfectly (I'm hardwired into it now).

Here's what I've done so far:

  1. Changed cat5 cables.
  2. "Reset" the router using the button on the back.
  3. Power cycled the modem and router multiple times.
  4. Changed to another cat5 cable.
  5. Tried using the Belkin setup utility already installed on my computer.
  6. Uninstalled and reinstalled the Belkin setup utility.
  7. Tried manually connecting by logging into the router and setting the connection type as dynamic IP and "cloning" the IP, then power cycling everything.

I'm at a loss for what to do at this point and would love some input.

Thank you.

share|improve this question
    
Try giving it a 30-30-30 reset (lots of videos on youtube show how), If it still has issues, it may be time to buy a new one. –  spuder Aug 5 '13 at 5:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.