Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows 8 Enterprise, on a domain account linked to a Windows Live ID. No Metro Apps will launch (Mail, SkyDrive or Windows Store).

When trying to launch Windows Store, the errors in the event log are (please pardon my french) :

  • Application: (5973) *Échec de l’activation de l’application winstore_cw5n1h2txyewy!Windows.Store avec l’erreur : Unknown HResult Error code: 0xc0020017 Pour plus d’informations, voir le journal Microsoft-Windows-TWinUI/Opérationnel.*

  • System: (7000) : Le service Service Windows Store (WSService) n’a pas pu démarrer en raison de l’erreur : Le compte spécifié pour ce service est différent du compte spécifié pour d’autres services s’exécutant dans le même processus. which should translate to The account specified for this service is different from the account specified for other services running in the same process.

My system is up to date with the latest updates. Note that if I double click on an image, I get a popup saying (translated) File system error (-1073610729).

I have tried running sfc /scannow without effect (the logs are enormous though, with a lot of missing files, or duplicate ownerships). wsreset.exe fails with the same error as above (File system error (-1073610729)). chkdsk /r /f solved nothing either.

A local account has the same problems on my machine.

I think everything worked when I installed the OS (from scratch), but this has been happening for a long time now, and I have no idea of what triggered this behaviour.

share|improve this question
    
please don't cross post the same issue in Technet and here. have you treid all suggestions from there? is the HD fine? What is the AppTroubleshooter telling you? –  magicandre1981 Aug 5 '13 at 13:10
    
Sorry about that, I didn't know about this rule. The original post is there social.technet.microsoft.com/Forums/windows/en-US/… Nothing worked so far (including the App Troubleshooter) so I thought I'd try for more suggestions here... –  Mac Aug 5 '13 at 13:32
    
it is not an official rule, but asking at 2 places makes it difficult to follow. Have you tried the HDD diag test? Also check the SATA cable. –  magicandre1981 Aug 5 '13 at 18:59
    
@Mac - Have you tried DISM /Online /Cleanup-Image /RestoreHealth by chance? The fact sfc /scannow detects missing files indicates your installation is corrupt. It might be time to simply reinstall. –  Ramhound Sep 11 '13 at 11:21

1 Answer 1

There are many posts related to Metro apps not installing or working when connected to a domain, I will post my solution here.

I found that metro apps are dependent on access to MANY registry and file locations.

I determined this by using Process Monitor by SYSInternals.

After playing around with registry and file permissions certain apps started working, including STORE, MAIL, CALENDAR, PEOPLE.

The permissions required are identified in this Microsoft document.

Warning: do not overwrite permissions of child objects in the registry - there are many child objects with custom permissions and it can make your problems worse

But other apps would STILL not open or would hang indefinitely including FINANCE, WEATHER, FOOD, TRAVEL, SPORTS.

Finally managed to fix it by giving "ALL APPLICATION PACKAGES" full control to the registry key:

HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.