Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an older Mac Pro running Lion 10.7.5 and I'd like to upgrade to Mountain Lion given that the machine is probably too old to run Mavericks. According to the specs my computer meets the requirements but there is a "supported model" list that specifies only Mac Pros 2008 or newer. Does anyone know how the App Store checks for that, if there is a way around the check or if working around the check is advisable?

Specs
Processor: Dual core 2.66 GHz Xeon
RAM: 9GB DDR2
Graphics: GForce 7300 256MB

share|improve this question

2 Answers 2

The App Store restriction is just there to prevent you from wasting money buying something you can't use. I presume you have the original Mac Pro "Quad Core" 2.66 (two dual-core CPUs = 4 cores total)? If so, the real limitation is that your Mac has 32-bit EFI firmware, and Apple doesn't support loading a 64-bit kernel from 32-bit firmware, and Mountain Lion's kernel is 64-bit only. (That, and I think they didn't include the drivers for some of the built-in hardware on that model.)

If you managed to install Mountain Lion on your Mac Pro, it would not be able to boot; I'm pretty sure you'd just get a little circle with a slash through it. To prevent this, the App Store will refuse to sell it to you, and even if you download it on another Mac, the Installer will refuse to install it.

share|improve this answer

I've not tried it myself, but lots of people have had success installing Mountain Lion on older machines, including 32-bit machines, using MLPostFactor. There is a big thread on it at Macrumors.

It looks pretty straight-forward, but I would definitely back everything up before you ran the program!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.