Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell Inspiron 15 n5050 laptop, 1.5 years old, with Windows 8 Pro installed on it.

Recently I have been having some problems with the USB ports. When I start my computer and insert any USB devices (mouse, pen drive, mobile) it doesn't work. A USB mouse makes my computer freeze for about 20 seconds.
But if I go to Device Manager (I can see some exclamation marks on the USB drivers) and uninstall all the USB drivers and scan for hardware changes, it reinstalls the USB drivers and starts working properly. Who knows why?

I have been experiencing this problem for the last two days. I upgraded Windows to Windows 8 nearly two weeks ago.

The problem repeats itself each time I shut down and start the computer again.

share|improve this question
    
Try uninstalling the usb drivers, and letting windows 8 find the best drivers itself. Also, check if you have legacy usb support enabled in the bios (it's usually safe to turn this off anymore). –  spuder Aug 6 '13 at 5:19
    
other users also have this issue with Intel 6 series chipsets: social.technet.microsoft.com/Forums/en-US/… –  magicandre1981 Aug 6 '13 at 18:59

3 Answers 3

Have you tried the drivers from Dells driver site I know you said it was Windows 8 and they don't offer a Windows 8 Download but I have downloaded Drivers for Vista 64 from manufactures sites to install on Windows 7 64 bit systems and have had no problems. It may be worth a try.

share|improve this answer

If you restart do you have the same issue? A "restart" in Windows 8 does a full-restart. If you choose "Shut down" it actually puts the computer into a hybrid hibernation state where the kernel is hibernated and then when you power back on that theoretically means a shorter boot time.

You can try to disable fast startup and that may help. If the devices are having issues with the hibernation of Windows then that may solve the issue. I have hybrid-boot (fast startup) disabled on my own Windows 8 machine and I find it takes no longer to boot than when it was enabled.

share|improve this answer
    
You are right. When I give a full restart to the system everything works properly. But I need a solution because normal startup takes more time than default. For now I have disabled fast startup. –  Bishal Aug 7 '13 at 15:59
    
I also tried to update the bios and the chipset drivers from the dell site but it says that installed ones are of latest version. –  Bishal Aug 7 '13 at 16:00
up vote 0 down vote accepted

I have found a solution to my problem. Thanks to all of you for your kind help. I enabled "USB wake up" in BIOS and that solved the problem. By default that was disabled.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.