Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is what I have got. Windows 7 Machine (64 Bit) running Virtual Box

This is what I am trying to do Get a 64 Bit of Linux running as a guest OS in Virtual Box.

This is my problem. I create a Linux Machine 2.6 (i think) and choose the defaults 3 GB RAM 40 GB (Virtual) HDD _ I choose both options Dynamic and Fixed

and then i present the ISO of the Linux Mint at boot time. So it boots up live CD All good so far.

I double click on the Install Mint (within the Guest VM) running live CD Linux.

It complains it cannot continue since it does not have 6.1 GB HDD space available to continue.

What am I doing wrong ? I have had no issues creating and running Windows VM. I am a Linux noob

share|improve this question
Are you booting into a setup? Or into a Live CD? If you are actually in a live setting and not a setup mode, you might have to mount the drive to use it. – Damon Aug 6 '13 at 4:56
@Damon yes you are correct, I am going into a live CD mode. And then I execute the icon for installing MINT from the live CD Operating system. Since I am (a complete) noob to Linux. Is this something I do from within the LIVE CD (USB actually) envrmnt. I will google on how to do this but if you have some ready links then that would be very helpful. – eklavya Aug 6 '13 at 23:19
Use this Should work. – Damon Aug 7 '13 at 1:24

Dynamic and fixed? Unless I'm mistaken, you have to choose one or the other. A dynamically expanding disk will report to the guest OS whatever size you told it to, and will expand, as needed, up to that size on the host device. A fixed sized vdi or vhd will report to the guest os the size that you told it to, and actually take up that much space on your host drive. The advantage of a fixed disk is that performance might be a little faster. I don't know of any scenarios where a vhd/vdi will be both dynamic and fixed.

share|improve this answer
Hi @SHD-X3 my bad. Should have been more clear. I tried this two times choosing a different option each time and ran into the same issue with the Linux Mint Installer as stated above. – eklavya Aug 6 '13 at 4:29
up vote 1 down vote accepted

Okay CRACKED IT !!! The bug is a virtualbox bug. It was not creating the virtual HDD.

At the point/ prompt where you are creating the Virtual HDD ... You are given a slider to choose the amount of HDD or you can input the number (say 50 GB). Instead of typing in the number ... choose the slider to indicate the amount (say 50 GB) . Then it creates the HDD

If you leave it as default (25 GB ). it works ... the issue is if you chose a number other than 25 GB by typing .. it won't create the HDD.

Use the slider peeps ... use the slider ... how frustrating... but it has been pleasure because I joined a community of bright people on superuser.

Answer is don't type the capacity of the Virtual HDD ... use the slider instead :-)

P.S: I never knew this forum existed.... thank you linux for opening my eyes to a bigger world.

Thank you everyone. @Damon, @spuder, @SHD-X3

share|improve this answer

The 5th question that pops up will ask if you want to make a dynamic or fixed hard drive. It will then show the following screen where you can choose the size.

enter image description here

The default for linux vm's is only 8gb. I'd recommend increasing it to 80. It is a pain to make this change after the VM is already running. It is best to throw it away, and create a new VM.

share|improve this answer
I actually did something close to it. Made it 50 GB but still not showing up inside the VM running the live CD. The question is how do I present that 50 or 80 Gbs to the live CD running the Linux Mint. – eklavya Aug 7 '13 at 0:32
Did you set 50 gigs before installing the OS? The partition will only be as big as the size of the harddrive you allocated. You'll need to resize the partition. – spuder Aug 7 '13 at 22:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .