Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been having connection troubles in my apparent for a year. Two or three wireless routers all perform about the same. My MacBook Pro also seems to work fine on other wireless networks.

I was about to accept that the wiring in this (old) apartment is just bad, but my internet speeds seem to speed up when I'm using it more. The best example is that downloads (e.g. via cyberduck) speed up from about 80 kb/s to ~ 300 kb/s when I'm also browsing the internet with (e.g.) chrome.

What could be causing this?

share|improve this question

1 Answer 1

Wireless by nature is very prone to interference. The fact that your downloads speed up when using chrome is likely a red herring.

Because wireless is so fluid, you should only consider speed tests reliable when connected over ethernet and the wireless is turned off.

Here is why wireless fluctuates so much:

Dynamic Rate Switching (DRS)

Wireless routers embody a technology called Dynamic Rate Switching. In the simplest sense, your laptop and access point 'negotiate' a safe speed they can both communicate at, depending on how strong the signal is.

You can see what rate your Macbook is transmitting at by holding the 'option' key while clicking on the wireless icon in your menu bar.


In my example, I have an RSSI of -55db (-45 to -70 or so are considered good, -80 to -90 are considered weak).

I have a transmit rate of 54 Mbps. You can see the full list of possible wireless speeds in the MCS Charts

enter image description here

Wireless Interference

It is possible that you are also in an environment where you are seeing a lot of interference from other wireless networks. The ISM band only has 3 non overlapping channels. If you see overlap in a program like wifi explorer, then it is likely your wireless will fluctuate. enter image description here

In other words, never count on wireless to give you consistent speeds. You should plug directly into the ethernet. My money says that the problem will go away.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.