Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a folder named "Attachments2". I'm working in windows 7 and am using zip.exe downloaded from cygwin to zip this folder.

In this folder there are folders and files which have Hebrew characters in their names and content (in the files' content that is).

The files and folders' names are not preserved as the origin but the files' content is.

Please help.

Regrards, Omer.

share|improve this question
1  
"The files and folders' names are preserved as the origin but the files' content is" ?? Please edit –  Jan Doggen Aug 6 '13 at 9:27
    
Do you mean "...but the files' content isn't."? If so, what's wrong with it. –  martineau Aug 6 '13 at 9:30
    
thanks, I meant that the file names and folders are not preserved as the origin but the content is –  omer bach Aug 6 '13 at 9:45

1 Answer 1

up vote 0 down vote accepted

You could use the free commandline tool 7z.exe from 7zip.

The version history of 7zip explicitely mentions its UTF-8 support:

- Unicode (UTF-8) support for filenames in .ZIP archives. Now there are 3 modes:
    1) Default mode: 7-Zip uses UTF-8, if the local code page doesn't contain required symbols.
    2) -mcu switch:  7-Zip uses UTF-8, if there are non-ASCII symbols.
    3) -mcl switch:  7-Zip uses local code page.

A recursive zip command with 7zip looks like:

7z.exe a -mcl -tzip attachments.zip -r Attachments2\*.*

Note: 7zip's own format .7z does not support codepages. You have to use the -tzip parameter to select the .zip archive format.

share|improve this answer
    
Tried it and it didn't work (files and folder names are gybrish)... any ideas ? –  omer bach Aug 7 '13 at 11:20
    
Which combination of switches have you tried? Please post the complete commandline. –  Axel Kemper Aug 7 '13 at 11:22
    
7z.exe a -mcu -tzip attachments333.zip -r 2013-08-07_10-16-32*.* –  omer bach Aug 7 '13 at 11:23
    
it is backslash and then . at the end, dont know why the it is not shown –  omer bach Aug 7 '13 at 11:24
    
I tried the same command you posted just with different values –  omer bach Aug 7 '13 at 11:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.