Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Our intranet has a Document Management system whereby a user can search for a file and then click a link (file:///) to open the containing folder with Windows Explorer.

Since moving to IE10, we have noticed that it doesn't work on some machines. (User clicks the link, but nothing happens.) I have tracked it down to whether a user has allowed / denied Windows Explorer access with the following pop-up:

enter image description here

I am assuming the ones that don't work are failing because the user has clicked "Don't Allow" and checked the "Do not show me the warning" check box.

How can I change this setting in IE10 if the popup is not being shown?

share|improve this question

migrated from serverfault.com Aug 6 '13 at 14:43

This question came from our site for professional system and network administrators.

add comment

2 Answers

You have fallen victim to IE's vicious Protected Mode Elevation Policies

Open the registry editor and locate the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Low Rights\ElevationPolicy\{20D04FE0-3AEA-1069-A2D8-08002B30309D}

This key controls the process integrity elevation policy for explorer.exe when launching from Protected Mode in IE

If the user pressed "Don't allow", you should be able to see a DWORD value named Policy, set to 0. Set it to 3, and explorer.exe will launch the file:/// links silently without prompting in the future.

It's all carefully explained in this developer guide at MSDN

share|improve this answer
add comment

The following worked for me:

  1. Go to Tools → Internet Options → Security → Local Intranet → Sites → Advanced
  2. Add the site that has open folder and files functionality.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.