Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a shared folder in a network which we all theoretically have access to. I edited through command line using icacls to grant everyone read and write permissions (icacls "Folder Name" /grant "Everyone":(R,W)). icacls also says that everyone should have full permission to this folder.

Originally the drive itself was shared, but its subdirectories were not being shared (despite that they were told to). So I then went into the folders security tab under properties, shared it with everyone by granting full access while I was the administrator, including under the advanced properties in the shared tab and in the security tab. This fixed the problem temporarily, but I was unable to copy files to the folder.

So I went back, attempted to grant more permissions if possible (wondering if copy/paste is a special permissions in Windows 8), and now the files are all back to read only. Any hints?

share|improve this question

1 Answer 1

This normally happens when you assign permissions to the file/folder level, but not the share itself. The two have separate sets of permissions.

ICACLS works on files and folders, so I would assume that the share is still set to Everyone RO, which is the default.

You can view the Share permissions by:

  1. Right-click the folder
  2. Click the 'Sharing' tab
  3. Click 'Advanced Sharing' button
  4. Click 'Permissions' button

Once you set that, you should be good to go.

share|improve this answer
    
I did that when I first assigned the share. I changed the permissions not only under the share tab with its advanced settings, but under the security tab. I also made sure that inheritance is enabled. Is there anywhere else I need to change it? –  KGaalswyk Aug 6 '13 at 19:56
    
Hrmm, that complicates things a bit more. Do you have conflicting permissions? Such as an explicit Read-Only from a different Role you have assigned? Also, you might want to update your question with that information so others don't make the same assumption I did. –  Taegost Aug 6 '13 at 20:53
    
I shouldn't, or if I do I'm not sure where they would be located. I've messed with other folders on other computers on the network, and I've been able to add/remove permissions with no problem. –  KGaalswyk Aug 6 '13 at 21:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.