Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Kubuntu 13.04 on an Acer Aspire One D270-1375 10 inch netbook running the Plasma Netbook.

Kubuntu goes to sleep fine, but when I push the power button to resume it I get multicolored vertical lines and a rather large square cursor that I can move around, all this with a black background in the back with no trace of the desktop or anything. If I am playing music and put it to sleep, the music starts to play again after I resume it, but still screwed up screen. I also can't hibernate it. I choose the hibernate option, but nothing happens at all. And until recently I couldn't control the screen brightness at all. It wouldn't change with the keys or in the options, but I installed some security updates and restarted, and now I can change the brightness.

I can't seem to find any other updates that might fix the sleep problem though.

Computer specs:
• 320GB hard drive dual boot Windows 7 (149GB Windows 7, 148GB Kubuntu)
• 2GB RAM
• 1.6GHz dual core CPU
• 320GB HDD
• 2.5GB swap space

I would appreciate any help or any tips I could try.

share|improve this question
    
Could you provide the model of the netbook? It should be on a sticker on the bottom (e.g. my Acer netbook says "Aspire One D270"). Certain Acer netbooks use the Intel GMA 3600 GPU, which is not well-supported in Linux. –  Typherix Aug 7 '13 at 5:45
    
it is a D270, is there any patch to fix the issues –  oaklandtony Aug 15 '13 at 21:22

1 Answer 1

The Acer Aspire One D270 series uses the Intel GMA 3600, based on technology by PowerVR. Intel only maintains drivers for Windows 7 32-bit. They did release a Linux driver in the past, though it is no longer available from their website.

In my experience, if you wish to run Linux on this machine, your best bet is Linux Mint 13 (and Ubuntu 12.04). Your recent success with the brightness controls is due to experimental support for this GPU in newer kernel releases, but they still lack proper graphics acceleration.

The Linux driver is available in the Ubuntu 12.04 repos (and so, Mint 13). You can install it with:

sudo apt-get update && sudo apt-get install cedarview-graphics-drivers

This should fix any brightness issues, as well as your resume problems. I can't guarantee that it will hibernate, as I haven't tried it. Unity felt a bit bloated on a small display, so I'd suggest installing a more lightweight DE. The Mint 13 XFCE version worked nicely for me. You may want to give Kubuntu 12.04 a try, in this case.

The ArchLinux wiki mentions that the Linux driver depends upon kernel 3.0/3.1 and Xorg 1.9/1.11, thus the lack of support in more recent versions. Judging from Intel's shoddy support for this card so far, I wouldn't expect a newer version to be written.

That wiki article also mentions an effort to port the DRM module to kernel 3.4-3.5 and 3.7-3.9. If you want to fiddle with that, you may be able to get a more up-to-date system working on this machine.

IIRC, HDMI and VGA out don't work well/at all on Linux, even with the drivers. If you need that functionality, you're better off using Windows.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.