Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am following directions to install JavaHL bindings for Subversion from: http://subclipse.tigris.org/wiki/JavaHL

It says to run sudo port install subversion-javahlbindings +no_bdb +universal when I do that I get an error

:info:configure configure: error: Cannot compile JavaHL without a suitable JDK.
:info:configure                   Please specify a suitable JDK using the --with-jdk option.
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_subversion-javahlbindings/subversion-javahlbindings/work/subversion-1.8.1" && ./configure --prefix=/opt/local --disable-dependency-tracking --with-apr=/opt/local/bin/apr-1-config --with-apr-util=/opt/local/bin/apu-1-config --without-apxs --mandir=\${prefix}/share/man --with-serf=/opt/local --with-sasl=/opt/local --with-libmagic=/opt/local --without-gnome-keyring --enable-javahl --without-jikes --with-junit=/opt/local/share/java/junit.jar --without-berkeley-db 
:info:configure Exit code: 1
:error:configure Failed to configure subversion-javahlbindings, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_subversion-javahlbindings/subversion-javahlbindings/work/subversion-1.8.1/config.log

I manually edited the Portifle and added the following to config.args:

--with-jdk=/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home 

I get the same error although I see that it did pass that argument to configure.

How do I specify a JDK for this operation to use?

share|improve this question
    
Not sure if this would work (which is why this is a comment, not an answer) but if you do export JAVA_HOME=/path/to/your/java and run this, does it help? – Rich Homolka Aug 7 '13 at 17:37
    
After that I get the same error in the logs. I also see it reporting :debug:main Discovered JAVA_HOME via /usr/libexec/java_home: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home that path appears to point to a valid JDK. – Freiheit Aug 7 '13 at 17:47
    
I'm wondering if this is an arch issue. Subclipse is telling me to install the +universal variant but I only have a 64-bit JVM installed so its likely it couldn't compile the 32-bit variant. Does Eclipse/Subclipse require a 32-bit JavaHL binding? – Freiheit Aug 7 '13 at 18:35

If you already have verified that your JAVA_HOME is pointing to the correct JDK, then try to export your variables with sudo's -E switch:

sudo -E port install subversion-javahlbindings +no_bdb +universal
share|improve this answer

I solved this problem by installing the latest version of Subclipse. I thought I had the latest installed through Eclipse Marketplace, but it was Subclipse 1.8.x. The latest is 1.10.x . I installed that using the Eclipse URL then running sudo port install subversion-javahlbindings with no options and everything works.

I'm not evne sure the macports install of the javahl bindings is necessary.

Subclipse download links: http://subclipse.tigris.org/servlets/ProjectProcess?pageID=p4wYuA

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .