Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a fully up-to-date, freshly re-installed debian sid box. Before I re-installed running

udisks --mount /dev/sdc1

would mount the disk to /media/<volume_label>, however, it is currently mounting the drive to /media/usb0.

I assume I am missing a package or have something configured wrong, but for the life of me can not figure out what.

I have not (to my knowledge) modified the udev rules outside of debian's package management. I have all the 'recommended' packages from udisks installed, but none of the suggested (as I don't need md, xfs, or reifer).

udisks version: 10.0.4.8 (downgrading to 10.0.4.7 didn't help). I am sufficently confused, I don't know what other packages are relevant here.

share|improve this question
    
I got your flag asking for migration to U&L... questions about Unix and Linux are fine on Super User, so you don't need to migrate it. Since you already figured out the answer, it's not like you'll be more likely to get a solution - since you already have one. If you would still like to have it migrated regardless, let me know with another flag or a comment, and I'll get it over there for you. –  nhinkle Aug 8 '13 at 17:06
    
@nhinkle Sent the flag before I figured out the answer. I don't know either of these SEs particularly well, so I will leave the migration decision to you. –  tcaswell Aug 8 '13 at 17:11
    
We'll leave it then @tcaswell - we generally avoid unnecessary migrations. In the future though you're welcome to ask linux questions on either site - it's up to you which community you think is most likely to have a good answer for you. –  nhinkle Aug 8 '13 at 17:40

1 Answer 1

up vote 0 down vote accepted

The problem was that I had a usb-disk attached during installation and the installer added a line to /etc/fstab which mounted /dev/sdc1 to /media/usb0. Removing that line (and /media/usb0) fixed the problem.

(The actual problem is that I apparently can't read as I checked this at the very beginning and missed it)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.