Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to get flash player working in my linux. No matter what I do I cannot seem to get it working. I have installed firefox 23 in ~/firefox. Ive copied libflashfplayer.so to the following locations.

[rbhat@rbhat-pc Downloads]$ sudo cp libflashplayer.so /home/rbhat/.mozilla/plugins

[rbhat@rbhat-pc Downloads]$ sudo cp libflashplayer.so /usr/lib/mozilla/plugins

[rbhat@rbhat-pc Downloads]$ sudo cp libflashplayer.so /usr/lib64/mozilla/plugins

[rbhat@rbhat-pc Downloads]$ sudo cp libflashplayer.so /usr/lib64/mozilla/plugins-wrapped

None of them seem to work. I dont remember installing flash player being quite so annoying. Has something changed?

The flash player I downloaded is flash-plugin-11.2.202.297-release.x86_64.rpm and im using Oracle linux.

share|improve this question
    
Not really an answer, but I had the same issues in Fedora. I have so far not figured it out, so I now use Firefox for normal web use and Chrome (which comes with flash installed already) for when I need to use flash. –  Nate Koppenhaver Aug 10 '13 at 20:50

2 Answers 2

Another option is ~/firefox/browser/plugins/libflashplayer.so. It was changed recently. I had to create folder plugins myself.

EDIT I can be wrong, but...

Place where you should link your libflashplayer.so depends on how did you install Firefox. If installation was done with system tools (packet manager) than Firefox binaries and libraries will go to /usr/bin and /usr/lib , etc. In this case linking flashplayer somewhere to /usr/lib64/mozilla/plugins probably will make sense, because Firefox was installed system wide.

But, if you download Firefox from Mozilla site and unpack it manually to your home folder, than Firefox will be looking for libflashplayer link in the ~/firefox/browser/plugins/libflashplayer.so because Firefox was installed for single user.

UPDATE

Here is helpful article which describes major changes in Firefox 21 including plugins directory.

share|improve this answer
    
I created a plugin directory under browser and copied it there. Still doesnt work –  Ram Bhat Aug 13 '13 at 3:09
    
Make sure directory name is plugins, not plugin –  Nikolay Aug 13 '13 at 12:04

Put it here: /usr/lib/firefox-addons/plugins/.

$ sudo cp libflashplayer.so /usr/lib/firefox-addons/plugins/
share|improve this answer
    
@Ram Bhat Have you tried my solution? –  benhuan Aug 13 '13 at 9:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.