Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently (since a business trip) my MacBook Pro running OS X Snow Leopard has been refusing to install software.

For example, when I try to install Unity3D I get this error:

The installation failed.
An unknown installation error occurred.

The installer encountered an error that caused the installation to fail.
Contact the software manufacturer for assistance.

And when I try to install SourceTree I get this error:

The Finder can't complete the operation because some data  in "SourceTree" can't be read or written.
(Error code - 36)

These errors occur as they are described above every time I have tried to install them (~10x each).

I am also experiencing incredible slowdowns (10-20x longer) on login (as of the trip - both problems began occurring at the same time).

I have run the Disk Utility and it suggested I repair my drive, which I have done. Now running the disk utility verification reports no problems for either the drive itself or the permissions.

Is there anything else that could be causing this? Is there any more information I could provide?

share|improve this question
    
I believe that your disk may be failing, although the problems are reported as fixed. Take care. –  harrymc Aug 11 '13 at 21:33
add comment

1 Answer

up vote 0 down vote accepted
+100

Here are some possible explanations. I've listed them starting from the simplest to check.

Software


Hard Drive writable

Make sure you aren't accidentally trying to install either program to an external drive, or any other file mount. I'll admit that I have mistakenly done this once.

Bad Download

Double check that your download arrived intact.

On the atlassian support page, an employee offers this suggestion to someone with the same error as you https://answers.atlassian.com/questions/75901/installation-error

I downloaded SourceTree 1.6.2.2 and successfully installed it. Compare your hash to mine.

$ shasum SourceTree_1.6.2.2.dmg 
6f3bf5d3ec339df5224f528e5f604f2cf6fe26b1  SourceTree_1.6.2.2.dmg

Mac 10.6 Bug

There is a bug in Mac OS X called the dot_clean bug. Take a look at this website for how to fix it. To avoid it, don't save the file to any DOS formatted drives.

Corrupted User

Try creating a new user account, and see if they can install it.

3rd Party Filesystem drivers

Make sure you aren't using any file system drivers like fuse.

Hardware


Bad Hard Drive

Take a look at your root directory, if you see a folder named 'DamagedFiles' it could be a sign that your hard drive is failing.

Scan for bad sectors with a program like Drive Genius or TechTool Pro

Run a hardware diagnostic

Take your laptop to a service provider. They will be able to perform a Netboot which will be able to further diagnose any other hardware issues.


Hail Marry

If all else fails, backup to time machine and perform a fresh install. When you restore from Time Machine, all your information will be restored exactly how it was before.

If you happen to have a blank external hard drive, install a fresh copy of Mac OSX to that drive, then hold the c during boot to choose which hard drive to boot from. See if the programs have the same install issues on the fresh OS.

Personal Thoughts

I've been repairing PC's and Mac's for 15 years. Because you are seeing significant slowdowns as-well, my gut tells me that it is likely a combination of hard drive failure, and file corruption.

Additional Resources

http://forums.macrumors.com/showthread.php?t=634655

share|improve this answer
    
Hi, thanks for such a detailed response. It's an internal hard-drive, the download's checksum is intact, tried the dot_clean fix to no avail, tried a new user account, I'm only using default drivers. Couldn't see a DamagedFiles folder anywhere. It's a company laptop, but the wait times for fixes (it's a university, go figure) are astronomical, so I thought if I could do it myself I would, and I was hoping to use it when I'm away on a conference. I think you're right about drive failure, good thing I'm gonna have to hand this thing back in a few months anyway. –  Nick Udell Aug 14 '13 at 18:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.