Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently updaed to icedove 17.0.7 which is basically thunderbird 17.0.7. As you might have guessed i use Debian.

When i try to fetch new mails i get this message: "There is not enough disk space to download messages..." (The message is in german though)

According to my df command:

    FILESYSTEM              TYPE     (=) USED      FREE (-) %USED AVAILABLE     TOTAL MOUNTED ON 
rootfs                  rootfs   [=========-----------]   44%     12,9G     22,9G /
udev                    devtmpfs [--------------------]    0%     10,0M     10,0M /dev
tmpfs                   tmpfs    [=-------------------]    0%    396,2M    397,0M /run
/dev/mapper/system-root ext4     [=========-----------]   44%     12,9G     22,9G /
tmpfs                   tmpfs    [=-------------------]    0%    992,0M    992,5M /dev/shm
tmpfs                   tmpfs    [--------------------]    0%    992,5M    992,5M /sys/fs/cgroup
tmpfs                   tmpfs    [--------------------]    0%      5,0M      5,0M /run/lock
tmpfs                   tmpfs    [=-------------------]    0%    100,0M    100,0M /run/user
/dev/mapper/system-home ext4     [=========-----------]   43%     35,9G     62,8G /home
/dev/mapper/system-tmp  ext4     [==------------------]    7%      1,7G      1,8G /tmp
/dev/sda1               ext2     [==------------------]    9%    431,8M    477,0M /boot
/dev/sr0                udf      [====================]  100%        0B      7,1G /media/Fedora-18-Multi-Desktop
/dev/sdb1               vfat     [=-------------------]    4%      7,2G      7,5G /media/TIFFANYWEH

there is enough space left on my disk to store those mails. Does somebody know how to fix this?

share|improve this question
    
just disabled my local disk quotas which i set up to save me from being unable to login when the disk gets full. these disk quotas do not allow me to use more than 95 % of the available diskspace. clearly this isn't the case here. –  l1zard Aug 9 '13 at 12:41
    
Where are the messages stored? –  terdon Aug 9 '13 at 13:40
    
on my /home at my local disk –  l1zard Aug 9 '13 at 14:25
    
This seems to be a bug in the version 17.0.7. I installed thunderbird version 17.0.8 from the homepage putting it to /usr/local/share/alternatives/thunderbird and linked it to /usr/local/bin/icedove also i linked the ~/.icedove to ~/.thunderbird. when i start thunderbird now with quotas enabled everything is working fine. –  l1zard Aug 10 '13 at 10:01
    
filed a bug report to the debian maintainers. –  l1zard Aug 10 '13 at 10:34

1 Answer 1

The Problem:

As i analysed the problem it occurs only with disk quotas enabled on the partition where your local profile is stored. Disabling quotas with

quotaoff -vau

does fix the problem with tunderbird/icedove. However the problem remains because in the environment i am working with the use of quotas is crucial.

The Solution:

My investigation on how to fix this problem came to the conclusion that there already is a fix for that so I downloaded the latest version of Thunderbird which is 17.0.8.

Untar the package like this:

tar xvfj thunderbird-17.0.8

and move the unpacked folder to a proper location like:

mv thunderbird /usr/local/thunderbird-17.0.8

Change into directory and link thunderbird to icedove.

ln -s /usr/local/thunderbird-17.0.8/thunderbird-bin /usr/local/bin/icedove

Set permissions on the folder:

chown -R root:root /usr/local/thunderbird-17.0.8/ && chmod -R 755 /usr/local/thunderbird-17.0.8

The final steps requires to link you profile to the the folder thunderbird will create.

ln -sf ~/.icedove ~/.thunderbird

Now start thunderbird by typing icedove in the konsole and it starts thunderbird with quotas enabled.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.