Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running emacs 24 and trying to change the colour theme but it's not working.

When I start emacs it displays in the default colours. I do M-x load-theme RET tango RET and the colours revert to white on a black background (other themes do the same thing).

I'm running emacs on debian wheezy through a putty window on a Windows 7 host. I've tried a local instance on debian with no change. I've tried both a pre-built package and building directly from a git mirror.

I'm something of an emacs newbie so it's possible I'm doing something stupid. Any help would be much appreciated.

Thanks,

share|improve this question
    
Have you tried just plain old M-x color-theme RET and then pressing the tab key or whatever the option is next? – lawlist Aug 10 '13 at 2:49
    
Doesn't seem to be a command M-x color-theme – Steve Homer Aug 10 '13 at 17:59
    
Well, that may be your problem -- i.e., color-theme is not properly installed, or it is not set up correctly. – lawlist Aug 10 '13 at 18:36
    
Do you have something like this in your .emacs file?: (require 'color-theme) (color-theme-initialize) (color-theme-robin-hood). – lawlist Aug 10 '13 at 18:43
    
Maybe I misunderstood -- your title says color-theme. There is no tango color theme included within color-theme by default: nongnu.org/color-theme Have you installed separately a theme named tango? – lawlist Aug 10 '13 at 18:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.