Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a really big problem.I currently had 2 hard drives, disk0 and disk1. I bought a Western Digital 1TB hard-disk a while ago and installed it on Windows 8 and it was placed as my disk 2.

I put all my data from long time ago in it and used it for about 5 months.

It was all fine 10 hours ago when I decided to install Windows 7 (in place of Windows 8). I formatted disk1 entirely (didn't mess anything with disk0 and disk2) and successfully installed Windows 7.

After the process was done I started Windows 7. The problem is that I noticed that Windows 7 doesn't seem to be able to deal with disk2 (1TB WD Hard Disk). Windows 7 can see it in Disk Management but doesn't even recognize the Free Space and the Used Space (should be 470gb used).

I can't even assign a letter to it, the only option I have is to Delete it. I tried many others software and they do the same, they partly recognize the 1TB hard drive, but doesn't seem to able to detect free-space and used space. They also seem not to be able to do anything with it but to able to delete it. Also, I noticed it probably is in some GPT Format.

I'm pretty sure I didn't do anything wrong with this disk in the Windows 7 installation process, and I didn't format it.

The data I have on it is really important and I can't afford to lose it. While all evidence points to the fact that the data is still there, I still have a lot of fear that the data is all gone.

What should I do?

To clarify more, here is the print screens from various programs :

http://s18.postimg.org/631wxsuh5/image.jpg

http://s21.postimg.org/78a0znovr/image.jpg

http://s11.postimg.org/uz63kvolf/image.jpg

http://s10.postimg.org/wad9bhrix/image.jpg

share|improve this question
    
Judging by your third picture, you should be able to right-click the partition and add a drive letter –  Canadian Luke Aug 9 '13 at 23:12

2 Answers 2

Recover the partitions using TestDisk.

share|improve this answer
    
Will i lose anything ? Any data ? –  nerdy Aug 9 '13 at 16:22
    
With any data recovery, there's a chance of losing data. As it stands right now, you don't have the data, so what do you have to lose? There are many other questions like this though, I would suggest you search for some @nerdy –  Canadian Luke Aug 9 '13 at 16:25
    
I was trying to understand the problem i'm facing. Does really recovery apply ? Isn't it a recognition problem ? I'm a lot confused, already tried to search in the internet –  nerdy Aug 9 '13 at 16:28
    
I recommend saving TestDisk until other options have been exhausted. The question is: What is the most reliable way to recover the data? TestDisk is useful, but it's one of the riskier ways of recovering data, so it's best to start with something less radical. gdisk can view the partition table and perform non-destructive tests; and there may be filesystem recovery options, too. (I'm not too familiar with Windows filesystem repair tools, though.) Using a Linux emergency disc to look for data (by mounting the partition, say) may be useful, too. –  Rod Smith Aug 9 '13 at 17:37

For some reason, it sounds like your system is having trouble reading a GPT disk. I'm guessing you see one large partition, and don't recognize it? You can read about this in this Windows and GPT FAQ

Win7 should have support for GPT, so this sounds very strange. Perhaps you used an MBR-only tool on the GPT disk that may have affected things?

In any case, I would try and create a sector-by-sector clone of the disk first, then maybe try a tool that can convert MBR to GPT. I haven't used that particular product, but it sounds like it might get the job done.

You might also try a linux rescue disk and GPT fdisk. There's a good section on that page about repairing GPT disks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.