Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

I've just got new laptop with Intel Atom N2800 on the board (wiki says that it is 64 bit) from shop with preinstalled Windows 7 starter 32 bit, and I want to install ubuntu 12.04 32 bit (exactly 32 becouse it will couse much less amount of troubles in usage, AFAIK) in dual boot, so from ubuntu mans I know that

if the other systems (Windows Vista/7/8, GNU/Linux...) of your computer 
are installed in EFI mode, then you must install Ubuntu in EFI mode too.

and from the same man page:

To install Ubuntu in EFI mode:    
Use a 64bit disk of Ubuntu (32bit installer does not detect EFI)

So, after all of that:

  • How to know in which mode windows is installed?
  • If it is in EFI - could I install ubuntu 32 bit with just BIOS?
  • If it is yes again - how can I do that?

I have already spent the whole day trying to do that, until I noticed that my laptop has that UEFI and started to google what is that and how to deal with it.

Update:

Ok, now I know that windows is installed in BIOS/Legacy mode, thanks to user @magicandre1981, next question is how to finally install 32 bit ubuntu in dual boot?

What I have tried already:

At first - I'm not sure about UEFI - BIOS screen is in blue and white oldschool colors, there are some rows that says BIOS information, BIOS vendor etc, but at the same time there are row that says Compliancy: UEFI 2.3, PI 1.2.

So, my problem:

All the distros that I have tried - ubuntu 12.04, 12.04.2, 13.04, latest mint - when they are loading their LIVE environment - nothing happens until I press any key - literally, even HDD activity led does no light up, I press space - a bit of loading process passes normally - changes picture on screen, lights HDD led, and then everythings hags and waits for the next press! pisses me out! then... 12.04.x and mint does not installs at all - hangs at random step, 13.04 installs when I keep space button pressed, but dies on next reboot (I will try again if there will be no success with other distros).

One wild Russian translation of the whole mint distro finally succesfully installed, but I still have to do not free for example the alt during installation, work that concerned with HDD operations, reboot and etc. But at least it works after reboot:)

As still the same ubuntu man says:

In your BIOS, disable QuickBoot/FastBoot and Intel Smart Response Technology (SRT).

But I do not see this options in my BIOS!

Update 2:

I write ubuntu and other iso images to the flash stick using UltraISO, may be I have to try unetbootin for example?

share|improve this question

marked as duplicate by Ƭᴇcʜιᴇ007, Mokubai, Tog, gronostaj, Dave M Aug 11 '13 at 17:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 4 down vote accepted

Windows 7 doesn't support UEFI with 32Bit. So it is BIOS/legacy mode.

share|improve this answer
    
ok, thanks a lot, could you please check my update to the OP post? –  scythargon Aug 9 '13 at 19:34
    
I use linuxliveusb.com for creating Linux USB drives. Post the name of your laptop. –  magicandre1981 Aug 10 '13 at 5:39
    
trying with LiLi, laptop is dns m116cc, but I think it is something chineese CLEVO for example (still dont know how to get the real model name) - our Russian shops likes to do tricks like this. –  scythargon Aug 10 '13 at 9:34
    
Look if you have a sticker on the buttom of your Laptop. –  magicandre1981 Aug 10 '13 at 12:56
    
yep, and it says exactly this model name –  scythargon Aug 11 '13 at 16:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.