Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a homebuilt system that has been giving me headaches on and off for the better part of a year. Whenever I try to shutdown, sleep or reboot (from Windows or BIOS), the system will appear to shutdown, but will not power off (fans and lights stay on). The only way to power it off is to hold down the power button for a few seconds. If I immediately try to turn the system back on, it will fail to POST. However, if I leave the system alone for an hour or so after powering it off, or unplug it or about 10 minutes, it'll start back up and boot to Windows without issue.

I have tried removing every component and powering it back on, save for the CPU, mobo or RAM, and nothing changes. I would replace a faulty component, but I don't know what to replace. The dependency on letting the system sit after power off makes me wonder if the issue is power related (either PSU or mobo). Interestingly, if I boot to linux on a separate hard disk, it will power down fine. This makes me wonder if the issue is related to the SSD Windows is installed on (the boot loader is on the SSD too, though).

I have updated every driver and BIOS multiple times. As of this post, all of the drivers, and the BIOS, available from ASRock are up to date. I also upgraded the SSD firmware successfully, but with some difficulty (due to the issue rebooting). I have looked at the Windows event viewer, and there are no errors or warnings when the command to power down is submitted. Windows seems to shut down correctly.

Given these symptoms, what would the likely culprit for these problems be? Would it most likely be a hardware problem (SSD, Mobo, PSU), or software problem (Windows, BIOS)? All of the remaining avenues for tackling this problem would involve spending money and/or data loss, which I would like to avoid if possible.

Here is the setup:

Asrock Z77E-ITX Mobo
Intel Core i5 3570K
Crucial M4 256 GB SSD (Primary drive) with Windows 7 64 bit
Segate 1TB HDD (Secondary) with Ubuntu 12.04
WD Caviar Green 2TB Drive (not in use)
Corsair 1600 low-profile DDR3 RAM, 2x4GB
EVGA GTX 660 ti
Antec Khuler 620 CPU cooler
FSP SF 450w PSU LG BDR Drive

Update I bought a new power supply and shutting down/sleeping/rebooting from Windows, Linux and BIOS. Unfortunately, after a hopeful 5 minutes, the old problems started resurfacing. The first time I shutdown from BIOS, it failed to POST. After that, when the system would POST, Windows failed to load half the time. This is actually a step backwards from the previous state (Windows never failed to load if the system POSTed).

share|improve this question
1  
If you suspect the Power Supply, what happened when you tried another known good one? In general, if you want to repair your own computer(s), you better be prepared to get extra parts for testing. :) Aside from that, backup and try a fresh Windows install. Does it behave the same way? –  Ƭᴇcʜιᴇ007 Aug 9 '13 at 18:24
    
To me it sounds like a program is not closing properly and gets stuck. Because you can close and fully power down with Linux, there could be an issue with windows. techie007 suggestion for trying a clean install sounds logical. –  Carl B Aug 9 '13 at 18:28
1  
If you are going to downvote, please leave a comment explaining how the question can be improved. Thanks. –  Will.CO Aug 9 '13 at 18:39
1  
I'm going to suggest you could improve this question: Before coming here, try dealing with the things that you say you suspect instead of just telling us what you suspect (falls under lack of Research Effort IMO). Make it into an actual (specific) question, as this one reads like a story about what's going on and your thoughts on it - not a question. There's not even an actual question mark anywhere! :) –  Ƭᴇcʜιᴇ007 Aug 9 '13 at 19:07
2  
Trying a Windows installation repair was going to be my next step, followed by a fresh installation if that did not work. Why? If the machine fails to POST (I'm going to assume that means 'does not power on' rather than 'give an error during POST') them this isn't a Windows issue. Windows isn't running at that point. If it's not powering up then nothing is running at that point and this would be a hardware issue. –  RobM Aug 9 '13 at 19:46

1 Answer 1

up vote 2 down vote accepted

As I can't comment on the post for being yet short on reputation, I'll file this as an answer.

Thinking logically, if the system won't boot to the OS, it can't be due to the OS (as RobM stated), but either HW or BIOS. Since changing the PSU didn't help, most likely it would be something related to he mother board.

I'd suspect that shutting down involves some BIOS calls, and googling for similar issues with that MB ended me up reading about this fancy thing Asrock calls Instant Boot that by description might, when failing to work correctly, cause weird things like this. If you have that feature available in the BIOS, make sure it's disabled. Either way, flashing with the most recent BIOS might also be a good option. It could also be the MB as others have also suggested, in which case I personally might prefer trying some other MB model (or even brand) in case it's a flaw by design and not just an individual bad piece.

share|improve this answer
    
Thanks for the comments. I am in the middle of putting a replacement motherboard through the paces, so we'll see how that goes. From doing some research, the power-down problems can be caused by Windows problems (like bad drivers). I thought that the inability to POST right after a shutdown might have been caused by Windows not sending the correct message to BIOS/motherboard and some residual power fudging the startup...or something like that. I have also read that a bad motherboard can not properly flush power from components at shutdown, causing the POST failure issue I have seen. –  Will.CO Aug 11 '13 at 3:42
    
Definitely there is an issue of a component retaining invalid status after shutdown, but I do not know if faulty chipset drivers could end up causing such a thing. –  zagrimsan Aug 11 '13 at 4:41
    
After a day of tests with the new motherboard, the problems I was having are nowhere to be seen. Looks like I found the problem! Thanks! –  Will.CO Aug 11 '13 at 21:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.