Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm developing an ASP classic site under Windows 7 (form a queue ladies). The problem is IIS seems to be heavily making use of its cache for both static and dynamic content which really conflicts with my 'make a small change, alt-tab, hit ctrl-F5' development style. Changes made to .asp files may take two or three refreshes to show up where as changes to .js files can take 20 times as many. How do I go about turning the caching off on my development machine?

Cheers.

in b4 stop using asp classic

share|improve this question

3 Answers 3

up vote 13 down vote accepted

Click on the server name then go to output caching.

Click Add Cache Rule then type the extensions - .aspx, .aspx.vb, .aspx.cs, .js etc. (not sure if you can do all on one)

Then simply either tick the prevent all caching or untick user-mode caching and it should stop IIS from keeping a cache of the pages.

Next time you do a full refresh, it should get the files from the hard drive and not the cache/memory




I do not currently have a machine with IIS7 on that I can muck around with so I Googled and found the picture below:

alt text

share|improve this answer
    
winrar. thanks wil. –  jammus Nov 20 '09 at 9:59

This blog might help: Response caching in IIS7.

It explains how this functionality can be controlled by editing system.webServer/caching section or by using IHttpCachePolicy intrinsic.

share|improve this answer

This answer helped me, (note: i'm using IIS8) link

I think its better to disable "Cache" of "Output Cache feature" by clicking the "Edit Feature Settings"

share|improve this answer
    
Welcome to Super User! Generally we like answers on the site to be able to stand on their own - Links are great, but if that link ever breaks the answer should have enough information to still be helpful. Please consider editing your answer to include more detail. See the FAQ for more info. –  slm Apr 17 '13 at 5:58
    
@slm thanks for your advise. I'll try to add more detail later –  Ata Iravani Apr 17 '13 at 6:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.