Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got a new ADSL router - ASUS DSL-N55U. It has a VPN Server function. I have configured it and have successfully connected to the VPN from a remove machine. However i can't see any computers on my home network from the remote machine (home network PCs and remote PC both run Windows 7). So the questions are:

  1. Is it possible?
  2. What am i missing?

What i wasn't sure about is the IP ranges. The VPN's client IP range is different to my home network's (192.168.10.* and 192.168.1.* respectively), so i'm not sure how a client PC can actually access my home network in the first place. Another point is my home network and the remote PC network both have the same IP ranges (192.168.1.*), so i'm wondering it that's causing any problems.

Any help would be appreciated.

About VPN configuration:

  • Network Place (Samba) Support: enabled
  • Broadcast Support: both (LAN to VPN Client & VPN Client to LAN)
  • Connect to DNS Server automatically: Yes
  • Connect to WINS Server automatically: Yes
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I have never seen this type of VPN setup before (likely it is very common). The current IP ranges are defeating the main purpose of a VPN. You will not be able to see your other devices (connected to 192.168.1.*) from your VPN (192.168.10.*) unless you do some trickery with bridges etc.

Solutions:

1) Change your VPN ip range to 192.168.1.xxx-xxx (on your router) and change the DHCP range so they don't conflict.

2) If you are not able to change the IP range for VPN, try updating the router firmware OR downloading an open-source router firmware (DD-WRT, Tomato, OpenWRT, etc)

3) If #1 and #2 do not work, you will have to create a VPN server on a standalone computer.

share|improve this answer
    
Thanks, @wolfo9999. I could actually change the VPN's client IP range. And this what fixed it! –  Muxa Aug 11 '13 at 20:49
    
Glad it worked :) –  wolfo9999 Aug 14 '13 at 0:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.