Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 2 monitors connected to a NVIDIA GeForce GTX 660:

  • Left is 1920x1080 via DVI (Samsung SyncMaster 2443BW)
  • Right is 2560x1440 via DisplayPort and is set to Primary (Samsung SyncMaster SA850)

I often leave my computer running overnight (working on long render job, doing backups, etc) so I only power off my monitors manually. However, if I power off the primary monitor, it is disabled completely as if it were unplugged from the graphics card (i.e. icons are moved, open apps are moved and resized to fit on the new primary monitor). If I switch from DP to a DVI cable, this does not occur. It seems to be an issue when using DisplayPort.

Is there a way to disable the monitor from being disabled completely in Windows when I power it off physically?

I have found no relevant settings in either Windows Display settings, nor the NVIDIA control panel software.

Edit #1: I'm using an Oehlbach Transdata DP 510 cable.

Edit #2: Here is a screenshot of my NVIDIA Control Panel v7.2.710.0: enter image description here

Edit #3: Here are screenshots of my Monitor configuration:

enter image description here

Clicking on Advanced settings reveals a Generic PnP monitor running at 59 Hz? 60 Hz is the only other option available.

enter image description here

Here is my secondary monitor which is connected via DVI:

enter image description here

Edit #4: If I open the "Screen Resolution" configuration panel and power the monitor off (via the power switch), this is what is shown:

enter image description here

It looks like I disconnected the monitor from the video card.

share|improve this question
    
My guess is that this is not an OS level setting. What graphics card do you have? –  user606723 Aug 11 '13 at 12:45
    
Are you using D-port to DVI converter? –  Nikolay Aug 13 '13 at 19:01
    
Added graphics card to my post. Also no, no connectors, just a rather expensive DP cable from Oehlbach (which according to Amazon reviewers was necessary to support this high resolution). –  glenneroo Aug 14 '13 at 17:51
1  
This isn't an NVIDIA-only thing. It's a monitor hardware thing. Displayport, I believe, has a HPD pin ("hot plug detect"). I believe that what happens is that when the monitor turns off, it brings that pin low, which then causes Windows to detect the display as disconnected, and then disables it. I don't know why this doesn't occur with DVI (or maybe it can). I experience the same thing on Windows 8, AMD Radeon HD graphics, with Samsung SyncMaster950D displays, but only when connected via Displayport. –  Ben Richards Aug 14 '13 at 18:04
1  
Not sure, but it seems that Microsoft fixed this issue Windows 8.1. –  mtm Sep 24 '13 at 9:06

11 Answers 11

up vote 1 down vote accepted

I've run into this issue as well and I've decided to write a little utility to restore the position and sizes of the windows on each of the screens. I unfortunately have an AMD card so the Nvidia solutions don't work for me.

This utility is very lean right now, but I will continue to improve it if anyone wants to use it.

http://www.ninjacrab.com/persistent-windows/

share|improve this answer
    
Works great but seems to have a bug with restoring some programs e.g. Winamp when turning DP monitor back on. Still a much better solution than putting the screen in sleep mode, which is easily interrupted if I accidentally bump the mouse (or table or someone walks too hard, which has happened quite often since using harrymc's solution over the last year). –  glenneroo Oct 19 at 15:04
    
Cool, I'll probably add logging to the next version and would love if you could send me over the trace so I can figure out what's going on and get it to work perfectly. Really glad it's helping you out. –  Min Oct 20 at 13:35
    
If you open source it on e.g. SourceForge I would gladly help contribute, assuming it's not written in some obscure language ;) Also I tried to contact you but there's no contact info on your webpage :( –  glenneroo Oct 20 at 19:35
    
Hey Glenn, I think I will go ahead and plop this on CodePlex, I totally welcome any support! I've also added a contact me form on my ninjacrab site so we can swap emails. –  Min Oct 21 at 6:36

DisplayPort acts as a PNP device, so turning off the monitor disconnects it from the computer as if it was removed and windows are moved out because Windows forgets this device, until it is turned on again and is "discovered".

One solution is to just let the screen go into sleep instead of turning it off. There are ways of programmatically forcing that, for example by using the monoff command in the free Wizmo utility to turn off all monitors.

Another solution for NVIDIA cards is detailed in DisplayPort Blanking / Screen Autodetect Problems by setting the monitor to use EDID information from a file instead of from the monitor, so auto-detected is not required.

This is done in NVIDIA Control Panel -> Workstation -> View system topology -> EDID source (for the monitor) -> Monitor... -> Export EDID.

Repeat this for each monitor. The topology should list the display as either EDID 'forced' or 'file'. See the linked article for more detail.

share|improve this answer
    
I have the latest NVIDIA drivers but I don't have the Workstation option nor System Topology anywhere in my settings. –  glenneroo Aug 14 '13 at 11:23
    
Please post a screenshot of your NVIDIA Control Panel, after checking in NVIDIA Driver Downloads if the "Automatically find drivers for my NVIDIA products" does find the same download file that you currently have installed. –  harrymc Aug 14 '13 at 12:49
    
Done and done and apparently I already had the latest version. –  glenneroo Aug 14 '13 at 17:50
1  
That workstation tab is probably limited to the Quadro series of cards, which is likely why you're not seeing it. Not sure if there's a workaround for the GeForce consumer series. –  ernie Aug 14 '13 at 17:55
    
A very long shot: Could you use regedit to go to HKLM\SYSTEM\CurrentControlSet\Enum\DISPLAY\{VESA_Monitor_ID}\{PnP_ID}\Device Parameters and see if the EDID key is defined. If you aren't sure which is your monitor's entry, right-click the desktop / Screen resolution / Advanced settings / Monitor / Properties / Details / Device Instance Path. Check whether the EDID key exists both when the monitor is on and off. Mind, I'm not sure that this will be of any help - just investigating. –  harrymc Aug 14 '13 at 19:41

Disable the "DisplayData Channel Command Interface" (DDC/CI) in your monitor settings.
As a result Windows will not recognize if you turn off your monitor and your desktop icons stay as they should. I successfully tested this on a Dell monitor!

Wikipedia descripes DDC/CI as follows. I'll just leave it at that. There isn't much about it on the net.

[...] DDC/CI specifies a means for a computer to send commands to the monitor, as well as receive sensor data from the monitor, over a bidirectional link. [...] Some tilting DDC/CI monitors support an auto-pivot function, where a rotation sensor in the monitor enables the operating system to keep the display upright as the monitor is moved between its portrait and landscape positions.

Most DDC/CI monitors support only a small subset of MCCS commands and some have undocumented commands. Many manufacturers did not pay attention to DDC/CI in the past, but now almost all monitors support such general MCCS commands as brightness and contrast management.

http://en.wikipedia.org/wiki/Display_Data_Channel#DDC.2FCI

enter image description here

(or)

Switch from DisplayPort to HDMI and block pin #19 with electrical tape.
Unfortunately this is only possible if monitor and graphics card have additional HDMI ports.

Female end (monitor)                 Male end (Cable)

enter image description hereenter image description here

  • Pin 19: Hot Plug detect (all versions) and HEC Data+ (optional, HDMI 1.4+ with Ethernet)

DisplayPort also has a Hot Plug pin (pin #18), but I doubt someone is able to tape this specific pin since DP connectors are just too small.

share|improve this answer
    
Great answer. However, what are the detection implications with covering up pin 19? I.e., with pin 19 covered, what does Windows "see" as happened to the monitor (I'm guessing pin 19 isn't a signal pulled high while connected)? More importantly, what will happen when the system reboots, if pin 19 is still covered? Will Windows not see the monitor? –  Coldblackice Oct 3 '13 at 5:15
    
I disabled DDC/CI but the monitor still goes undetected when switched off. Looks like loss of DisplayPort signal from a switched off monitor is the same as cable disconnect. –  icelava Dec 30 '13 at 14:08

Check the solution in the following post (Friday, September 16, 2011 8:28 PM): http://social.technet.microsoft.com/Forums/windows/en-US/8a9b5aa7-fe33-4e6d-b39b-8ac80a21fdc2/disable-monitor-off-detection-how#c6e69e04-c0a5-44e1-a87e-7d83efb38efd

This is a very long thread - if the above way does not work for you, maybe the following solutions there can help you?!

share|improve this answer
    
I think the option to work with custom EDID information is only available on Quadro cards. –  glenneroo Aug 14 '13 at 20:25

Guys - This was my entire solution. I had to do all 3 of these things to get it to work.

  1. Update your Nvidia Drivers to the latest version and restart your computer
  2. Go into each monitor and turn off the DDC/CI ability (DISABLE IT)
  3. Follow these instructions: https://sites.google.com/site/ebobster/stuff/displayportblanking

This will work for you. I had to hack at this a while to figure this out. It's a combination of all of these things to get it to work properly. You might have to reload your EDI files more than once to get it to work but you can succeed. :)

There is no reason to disable pin 19 to get this to work if you follow my instructions.

share|improve this answer
    
How do you do step 2? What is DDC/CI ability? Where do I disable it? BIOS? Control panel? More detail needed. Also in the instructions for step 3 which you linked, on that page on step 2, the "Workstation" tab isn't listed in my control panel. I am guessing it's only available on NVIDIA Quadro cards. –  glenneroo Jun 23 at 20:34

There's little chance of this ever being seen but I'll post it anyway. I'm not sure if this applies to all Samsung monitors, but, on my SyncMaster BX2031, I found that if I go to the monitor's built in menu, go to "Setup & Reset" and set "Magic Return" to "off", I don't have the issue. I think this is Samsung's attempt at saving on system performance by disabling an unused screen. However, I'm not entirely sure if this is the only function of the feature so be safe about it.

To clarify, on samsung monitors go to [Menu -> Setup & Reset -> Magic Return -> off]

share|improve this answer
    
I had pretty much the same problem with my HP Monitor and turning off the "Power Saver" features solved it for me. –  Michael Tunnell Jul 28 at 16:59

Not a fix, but a workaround. I noticed that if you minimize windows before the display is powered off and do not restore them until the display has returned, then the windows are not rearranged.

I leverage that fact to provide a 'seamless' experience for myself as I have documented here: http://thelamprechts.blogspot.com/2014/09/a-windows-workaround-to-maintain-window.html

share|improve this answer
    
Instead of writing the same answer on two questions, you should probably use the [flag] button to suggest that one question is a duplicate of another. –  Kevin Panko Sep 28 at 5:34

A "simple" registry change, taken from here. It works for me mostly. Programs snapped to the lower right corner are moved ~300px closer to the center on my 4k screen, but I can deal, especially since it means I won't have to install a 3rd party app:

Using Sysinternals ProcessMonitor I found that Windows was accessing the following Registry path;

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration

My system had three entries;

DELF003YY7707BR0MUL_30_07D7_6A^9A3774EB79DEE3E3E38496CC7DF4D936
QHD32000001_31_07D6_D5^63E1ABDD175E7871DCAEB710418A0F75
SIMULATED_8086_2A42_00000000_00020000_1010100^CDE365D1B3F0942F0CF38BFB8E127AB4

Under each is a tree called "00" two of the keys are PrimSurfSize.cx PrimSurfSize.cy

Under "00" was another branch also called "00" two of the keys are; ActiveSize.cx ActiveSize.cy

The first two of the configs (ie DELF00... & QHD3...) the above keys were 1440x900, so they were not involved.

The third (SIMULATED...) were set to 1024x768.

I changed these to 1600x900 and the problem was solved.

Further I changed resolution (via control panel) to 1920x1080, the moving/resize issue returned, but the lower right corner was set to 1600x900, ie the SIMULATED... settings." Use MichealAtOz's advice but within all the folders that are labeled "00" or "01", (etc, I had 00 and 01) look for any settings that contain 1024, 768, or I 4096 in the data values at the end in parenthesis. Change the 1024 to the x resolution of your desktop (the first number in resolutions) and the 768 to the y resolution of your desktop. Change the 4096 number of "Stride" to whatever number there already is in a "00" or similar titled folder that already has (without you changing them) the desired desktop resolution numbers in primsurfsize.cx and ...y. Right click the name and choose modify, then select binary as the base to enter correct resolution values.

share|improve this answer

Try to set D-port monitor as main display both in BIOS and Windows Display Settings.

Source: This article

share|improve this answer
    
Good try, it's already set to primary in Windows and I have no such BIOS option because I'm not using on-board graphics. To quote from the article, "If you are using the onboard integrated graphics card of the M58p and M58, and want to use two external monitors. You should set the primary display to displayport and secondary display to vga in both the windows and bios environment." –  glenneroo Aug 14 '13 at 17:54

The taping up the pin does work, but it is quite hard to get the tape angled right. Also once you get it taped up and ready to go don't ever unplug the cable or you may have to retape it. It took me forever to get the taped lined up on the hdmi cable just like

share|improve this answer

Try this:

  1. Go to Control Panel> Power Options.
  2. Edit the plan you use by clicking Change Plan Settings.
  3. Once here click Change Advanced Power Settings.
  4. Once there, go to USB Settings, open the menu by clicking the +, and open the next menu named USB Selective Suspend Setting. Disable it.
  5. Once this is disabled, Windows 7 will no longer adjust your display setup when a display is turned off.

I just tested it, and it works for my double screen setup (HP ZDisplay Z23i 23" SCreens) with Win 7 and GeForce GT630.

share|improve this answer
    
USB Selective Suspend Setting was already disabled on my system. –  glenneroo 2 days ago

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.